cancel
Showing results for 
Search instead for 
Did you mean: 

EA Server using 100% CPU

Former Member
0 Kudos

Hi there,

I have a client running PB10, using EA Server 5.2. Every so often, the CPU on the EA Server machine spikes to 100%.

Can anyone please recommend a solution? How to monitor the EA server and what to look for?

Thanks in advance for your help.

P.S I believe this question has been asked before, but I have not seen any resolutions.

Accepted Solutions (0)

Answers (2)

Answers (2)

cpollach
Explorer
0 Kudos

Hi Pradeep;

Its hard to theorize from your general description one whether its an application bug, one caused because EAServer 5.2 is so old its driver's probably do not comply with newer O/S's, or your application is hitting a bug that was fixed in a much newer release. Unfortunately, EAS is now an EOL'ed product - so upgrading may no longer be an option. Note that even if you could upgrade to the last release ( v6.3 ) - EAS is still only 32bit in nature.

Regards ... Chris

Former Member
0 Kudos

Thanks Chris.

Agree with everything you said. Was hoping someone having experienced something similar and would be able to give me some hints. I have the customer eagerly awaiting for a response and I don't have any specific at this stage.

CobyKako
Advisor
Advisor
0 Kudos

Hi Pradeep,

Giving a solution without knowing the whole context of your application may be challenging. It is a common error to instantiate PowerBuilder components without destroying them after usage.

My proposal would be to take a look at the following EAServer 5.2 docs, especially the:

  • Performance and Tuning Guide
  • Troubleshooting Guide

Kind regards,
Jacob

Former Member
0 Kudos

Thanks Jacob, for your response. I had already downloaded the docs but not getting far quickly with the large documents.