cancel
Showing results for 
Search instead for 
Did you mean: 

Docker Build errors in SAP Data Intelligence

shishupalreddy
Active Contributor

Hello,

The necessary python libraries have been putinto Docker file as specified in various blogs and tried to build Docker image , but so far no luck.

Can any suggest/share the working docker image file on SAP DI Trail version asap...

FYI - I have been trying all the possible answers given in community , but no success hence requesting the working solution ... Thank you

Vitaliy-R
Developer Advocate
Developer Advocate
0 Kudos

Can you please share the content of your Docker file, plus information what kind of error or other issue you are facing when building it?

swapan_saha
Advisor
Advisor
0 Kudos

Hello,

Is this docker question related to SAP Data Intelligence trial or in general related to the SAP Data Intelligence product? Please provide additional info with the context and steps.

Thanks,

Swapan

shishupalreddy
Active Contributor
0 Kudos

Hello , Thank you for your responses.

I was using Trail version at CAL .

As my AWS instance is incurring costs with no progress on my use case with SAP DI, I got to close the account.

I am not sure if these issues are with Trail account alone, becoz I tried to evaluate some use case back in end of 2020 as well and ended with errors.

However below is the Docker file I have used to build and respective errors.

FROM $com.sap.sles.base

RUN pip3.6 install --user numpy==1.16.4

RUN pip3.6 install --user pandas==0.24.0

RUN pip3.6 install --user sklearn

Error :"error building docker image. Docker daemon error: The command ‘/bin/sh -c pip3.6 install –user numpy==1.16.4’ returned a non-zero code: 1"

FYI - I have followed multiple threads in SAP community on the same error but unfortunately ended with same errors.

Thank you

Shishupal.

jimgiffin
Product and Topic Expert
Product and Topic Expert
0 Kudos

This one works on my current DI Cloud:

FROM $com.sap.sles.base

RUN python3.6 -m pip install numpy==1.16.4 --user

RUN python3.6 -m pip install pandas==0.24.0 --user

RUN python3.6 -m pip install sklearn --user

Notice it is using python3.6 install instead of pip3.6 install.

Accepted Solutions (0)

Answers (0)