cancel
Showing results for 
Search instead for 
Did you mean: 

Disabling FORWARD option in UWL

Former Member
0 Kudos

Hi,

We are on SRM 7.1

Is there a way to disable the "FORWARD" option in UWL completely?

Do I need to modify the iview property or change something else in UWL in Portal?

Please advise.

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

There is always a danger that if you remove the forwarding for whole UWL, there is some other usage (other than SRM?) who need this functionality. Or it might pop up later that some new workflow will need the forwarding functionality.

If it happens to be that you need to restrict the forward only from certain tasks, you need to modify the XML configuration for item types. You can do it with this kind of line:

<Action name="forward" handler="dummy">

Also, other option is that you set up the tasks in the backend properly. For example if you have an approval task for shopping cart, you can open the approval task in the backend and set up "forwarding not allowed" functionality.

Regards,

Karri

Former Member
0 Kudos

Thanks Shanti/Karri.

Karri,

CAn you please explain how do i set the task properties for the forward feature?

Former Member
0 Kudos

Hi,

If you are not supposed to ever forward a task to another user, I would change the task properties in the backend system. If you know the task ID, you can open it in transaction PFTC. Then from the menu you will find a possibility to maintain the agent assignment of the task. Now I don't have an access to a system from which I could check the menu path, but if you search in SDN about how to set a task as a "general task", you should be able to find the correct path in some thread. The "Forwarding not possible" setting can be set up at the same place as where the task can be set as "general task" (=whoever can complete the task and it can be forwarded to anyone). I could perhaps check the menu path tomorrow, if you are not able to find it.

If you need to know the how to configure the item type in UWL (you don't need to do this, if you do the above), you need to e familiar about UWL configuration in general before you can do this. I would suggest that you try the above solution, before trying to do UWL configuration unless there is a specific reason for it (for example you need to be able to forward the task in backend but not in UWL).

Regards,

Karri

former_member201257
Active Contributor
0 Kudos

If you want to remove forward action for all the UWL items, it should be simple.

Open the UWL iview and look for a property called "List of UWL actions to exclude".

In that property enter the value "forward" .

forward - Forward

http://help.sap.com/saphelp_nw04/helpdata/en/fd/8bf6d1b0484ec7ade4369792a22293/content.htm

This should remove the forward action for all the UWL items.

Thanks,

Shanti