cancel
Showing results for 
Search instead for 
Did you mean: 

DHAPE_CREATE_OPERATOR_CLASS program - Protocol Version parameter

RafaelSoares
Explorer
0 Kudos

Hi DI Experts!

I need to create an ABAP Class to use as an Operator but I don't know how to fill Protocol Version parameter in DHAPE_CREATE_OPERATOR_CLASS program. This parameters has to do with Subengines version and possible values are v6 or v7.

Could someone please tell me more about this parameter?

Thanks in advanced.

View Entire Topic
michal_majer
Active Participant

Hello rafa.soares,

Currently in SAP DI there 2 generations of the operators.

v6 is ABAP Subengine generation 1
v7 is ABAP Subengine generation 2

abap:

{
    "versions": [
        "6"
    ],
    "tags": {},
    "types": ["abap"]
}
abap2:
{
"version": 7,
"tags": {},
"command": "run.sh",
"args": [],
"env": []
}

Depending in requirements / generation you have to select appropriate version during custom ABAP operator implementation.

Subengines: https://help.sap.com/docs/SAP_DATA_INTELLIGENCE_ON-PREMISE/aff95eebc2e04c44816e6ff0d21c3c88/20fad0ff...

Best,

Michal