cancel
Showing results for 
Search instead for 
Did you mean: 

Deployment of srv and db modules of a CAP Project from Business Application Studio fails

vishali3
Explorer
0 Kudos

Hello everyone,
I have been trying to deploy my CAP Application in CF when I am facing a few errors.

The steps I followed are as follwos:

  1. added dependencies for hana in package.json
  2. did "npm install" and "cds build"
  3. Added the mta.yaml file using "cds add mta"
  4. Added the necessary approuter files for deploying the UI Module(also files such as xs-app.json and xs-security.json)
  5. Built the MTA.yaml file
  6. Deployed the mta archives - .mtar file.

    I had specified the right path to the ui module. The srv and db module's paths are autogenerated in mta.yaml. I have not made any custom changes there.

    So when I deployed it, I was getting this following error:
Creating application "ABC_LPR_ShiftAssignment-srv" from MTA module "ABC_LPR_ShiftAssignment-srv"...


Creating application "ABC_LPR_ShiftAssignment-app-router" from MTA module "ABC_LPR_ShiftAssignment-app-router"...


Creating application "ABC_LPR_ShiftAssignment-db-deployer" from MTA module "ABC_LPR_ShiftAssignment-db-deployer"...


Binding service instance "ABC_LPR_ShiftAssignment-db" to application "ABC_LPR_ShiftAssignment-srv"...


Binding service instance "ABC_LPR_ShiftAssignment-db" to application "ABC_LPR_ShiftAssignment-db-deployer"...


Binding service instance "ABC_LPR_ShiftAssignment_uaa" to application "ABC_LPR_ShiftAssignment-app-router"...


Uploading application "ABC_LPR_ShiftAssignment-app-router"...


Uploading application "ABC_LPR_ShiftAssignment-srv"...


Started async upload of application "ABC_LPR_ShiftAssignment-app-router"


Started async upload of application "ABC_LPR_ShiftAssignment-srv"


Uploading application "ABC_LPR_ShiftAssignment-db-deployer"...


Started async upload of application "ABC_LPR_ShiftAssignment-db-deployer"


Scaling application "ABC_LPR_ShiftAssignment-db-deployer" to "1" instances...


Scaling application "ABC_LPR_ShiftAssignment-srv" to "1" instances...


Scaling application "ABC_LPR_ShiftAssignment-app-router" to "1" instances...


Staging application "ABC_LPR_ShiftAssignment-srv"...


Staging application "ABC_LPR_ShiftAssignment-app-router"...


Staging application "ABC_LPR_ShiftAssignment-db-deployer"...


Error staging application "ABC_LPR_ShiftAssignment-srv": NoAppDetectedError - An app was not successfully detected by any available buildpack


Download the application logs via the dmol command and check them for more information.


A step of the process has failed. Retrying it may solve the issue.


Proceeding with automatic retry... (3 of 3 attempts left)


Staging application "ABC_LPR_ShiftAssignment-srv"...


Error staging application "ABC_LPR_ShiftAssignment-srv": NoAppDetectedError - An app was not successfully detected by any available buildpack


Download the application logs via the dmol command and check them for more information.


A step of the process has failed. Retrying it may solve the issue.


Application "ABC_LPR_ShiftAssignment-db-deployer" staged


Executing task "deploy" on application "ABC_LPR_ShiftAssignment-db-deployer"...


Proceeding with automatic retry... (2 of 3 attempts left)


Staging application "ABC_LPR_ShiftAssignment-srv"...


Error staging application "ABC_LPR_ShiftAssignment-srv": NoAppDetectedError - An app was not successfully detected by any available buildpack


Download the application logs via the dmol command and check them for more information.


A step of the process has failed. Retrying it may solve the issue.


Execution of task "deploy" on application "ABC_LPR_ShiftAssignment-db-deployer" failed.


Download the application logs via the dmol command and check them for more information.


A step of the process has failed. Retrying it may solve the issue.


Proceeding with automatic retry... (1 of 3 attempts left)

The Approuter is getting deployed , whereas the srv is not getting deployed.
Has anyone else faced the same issue? Any pointers on how to resolve this issue would be of great help.
Edit : I have also attached the screenshots of the project structure and the mta.yaml relevant code for reference.


Thanks,
Vishali

View Entire Topic
mariusobert
Developer Advocate
Developer Advocate

That error message means that the Cloud Foundry runtime couldn't determine which buildpack to use for the app. Usually that means that there is no package.json file in the module.

Please have a look at the module path in the mta.yaml and confirm that the package.json file is in there. It should be generated automatically from cds build but that behavior can be customized. Maybe that's what's happened.