cancel
Showing results for 
Search instead for 
Did you mean: 

deployment of par files via remoteGui does not work

Former Member
0 Kudos

Hello,

I packaged a couple of pars with par2sda and sca and started a deployment in remoteGui. Some sdas were successfully deployed, but one of them throws the following exception. I played around a little with SAPJ2EE::... entries in the par's portalapp.xml, but didn't get it working. Here is the portalapp.xml entry:

<application-config>

<property name="PrivateSharingReference" value="com.siemens.pct.com.base._._.parf.localization,com.siemens.pct.com.base._._.parf.configuration,com.siemens.pct.com.base._._.parf.redirect,com.sap.portal.productivity.desktop,com.sap.portal.desktop.desktopservice,com.sap.portal.themes.lafservice,com.siemens.pct.eps.smv._._.parf.framework,SAPJ2EE::sap.com/com.sapportals.prt.portalruntime "/>

</application-config>

Feb 9, 2006 9:27:50 AM Info: Starting: Initial deployment: Selected development component 'com.siemens.pct.com.base._._.parf.footer'/'siemens.com'/'LOCAL'/'20060209092717' will be deployed.

Feb 9, 2006 9:27:50 AM Info: SDA to be deployed: D:\usr\sap\PDE\JC00\SDM\root\origin\siemens.com\com.siemens.pct.com.base._._.parf.footer\LOCAL\20060209092717\com.siemens.pct.com.base._._.parf.footer.ear

Feb 9, 2006 9:27:50 AM Info: Software type of SDA: J2EE

Feb 9, 2006 9:27:50 AM Info: ***** Begin of SAP J2EE Engine Deployment (J2EE Application) *****

Feb 9, 2006 9:27:54 AM Info: Begin of log messages of the target system:

06/02/09 09:27:50 - ***********************************************************

06/02/09 09:27:50 - Start updating EAR file...

06/02/09 09:27:50 - start-up mode is lazy

06/02/09 09:27:50 - EAR file updated successfully for 47ms.

06/02/09 09:27:50 - Start deploying ...

06/02/09 09:27:51 - EAR file uploaded to server for 125ms.

06/02/09 09:27:54 - ERROR: Not deployed. Deploy Service returned ERROR:

com.sap.engine.services.rmi_p4.MarshalException: Exception when trying to read the original exception.; nested exception is:

java.lang.ClassNotFoundException: com.sapportals.portal.prt.runtime.PortalException

Thanks for your help,

Elmar

Accepted Solutions (0)

Answers (1)

Answers (1)

detlev_beutner
Active Contributor
0 Kudos

Hi Elmar,

the entry <i>SAPJ2EE::sap.com/com.sapportals.prt.portalruntime</i> is superflous.

If you're lucky, the original exception got logged into default.X.trc, just check it.

Hope it helps

Detlev

Former Member
0 Kudos

Hello Detlev,

Thanks for the hint taking a look into the log file. It lead me in fact into the right direction. I had network problems during the deployment so the system somehow fell into an inconsistent state. I reinstalled my PDE and then the deployment was successful.

Sorry for any inconvenience.

Just one more question: I produced an sca file called comsiemens00_0.scawith the SAP make utilites. How can I manipulate the zero numbers?

Thanks,

Elmar

detlev_beutner
Active Contributor
0 Kudos

Hi Elmar,

sorry, I don't know. I only have experience packaging manually the PAR into an EAR and then deploying this directly 😐

Bets regards

Detlev