cancel
Showing results for 
Search instead for 
Did you mean: 

Deploying .net 2008 application having crystal report in web server

Former Member
0 Kudos

HI expert,

Im having problem deploying my application created in .net 2008 and the embeded crystal report basic 2008 in our web server. In my local machine it works fine but when i deploy it it gives me error:

Could not load file or assembly 'CrystalDecisions.Web, Version=10.5.3700.0, Culture=neutral, PublicKeyToken=692fbea5521e1304' or one of its dependencies. The system cannot find the file specified.

Source Error:

Line 87: </customErrors>

Line 88: -->

Line 89: <httpHandlers><add verb="GET" path="CrystalImageHandler.aspx" type="CrystalDecisions.Web.CrystalImageHandler, CrystalDecisions.Web, Version=10.5.3700.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/></httpHandlers></system.web>

Line 90: <system.webServer><handlers><add name="CrystalImageHandler.aspx_GET" verb="GET" path="CrystalImageHandler.aspx" type="CrystalDecisions.Web.CrystalImageHandler, CrystalDecisions.Web, Version=10.5.3700.0, Culture=neutral, PublicKeyToken=692fbea5521e1304" preCondition="integratedMode"/></handlers><validation validateIntegratedModeConfiguration="false"/></system.webServer><businessObjects><crystalReports><reportMappings><add reportName="CSR0003.rpt" path="CSR0003.rpt"/><add reportName="APPAReport.rpt" path="Reports\APPAReport.rpt"/><add reportName="CSRReport.rpt" path="Reports\CSRReport.rpt"/><add reportName="CYTAReport.rpt" path="Reports\CYTAReport.rpt"/><add reportName="LORReport.rpt" path="Reports\LORReport.rpt"/><add reportName="OADPReport.rpt" path="Reports\OADPReport.rpt"/><add reportName="RNVReport.rpt" path="Reports\RNVReport.rpt"/></reportMappings></crystalReports></businessObjects></configuration>

Source File: E:\inetpub\wwwroot\scmreport\web.config Line: 89

Assembly Load Trace: The following information can be helpful to determine why the assembly 'CrystalDecisions.Web, Version=10.5.3700.0, Culture=neutral, PublicKeyToken=692fbea5521e1304' could not be loaded.

I look for the error and i found the redistributable package: CRRedist2008_x86.msi. I run this on our web test server and my application works fine.

But the problem is, when i test the old application (created in .net2003 and the embedded cr report) i got this error:

File or assembly name CrystalDecisions.CrystalReports.Engine, or one of its dependencies, was not found.

Source Error:

Line 22: debugging ASP.NET files.

Line 23: -->

Line 24: <compilation defaultLanguage="vb" debug="true"><assemblies><add assembly="CrystalDecisions.CrystalReports.Engine, Version=9.1.5000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/><add assembly="CrystalDecisions.ReportSource, Version=9.1.5000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/><add assembly="CrystalDecisions.Shared, Version=9.1.5000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/><add assembly="CrystalDecisions.Web, Version=9.1.5000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"/></assemblies></compilation>

Line 25:

Line 26: <!-- CUSTOM ERROR MESSAGES

Source File: E:\INETPUB\WWWROOT\DTS\web.config Line: 24

Assembly Load Trace: The following information can be helpful to determine why the assembly 'CrystalDecisions.CrystalReports.Engine' could not be loaded.

=== Pre-bind state information ===

LOG: DisplayName = CrystalDecisions.CrystalReports.Engine, Version=9.1.5000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304

(Fully-specified)

LOG: Appbase = file:///E:/INETPUB/WWWROOT/DTS

LOG: Initial PrivatePath = bin

Calling assembly : (Unknown).

Please need your hep.

Thanks

Edited by: Zhiele Swing on Sep 8, 2009 8:39 AM

Edited by: Zhiele Swing on Sep 8, 2009 8:39 AM

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

VS 2008 supports Crystal 10.5, try using visual studio integration manager and change the version from 10.5 to 12.0, you may download VSIM from here

http://www.sdn.sap.com/irj/boc/crystalreports-dotnet;jsessionid=(J2EE3414800)ID1775426450DB004615511...

hope this helps.

Answers (3)

Answers (3)

former_member183750
Active Contributor
0 Kudos

You have to install the correct CR runtime. See [this|https://wiki.sdn.sap.com/wiki/display/BOBJ/CrystalReportsforVisualStudio.NETRuntimeDistribution-Versions9.1to12.0] wiki for more details.

Ludek

Former Member
0 Kudos

Hi is VSIM only applicable to local machine? how about in server? do i need to install VSIM to run my application with crystal report?

Please help me resolve my problem..

Former Member
0 Kudos

Hi,

Please make sure you have the correct assemblies in the server also.

Wiki:

https://wiki.sdn.sap.com/wiki/display/BOBJ/CrystalReportsforVisualStudio.NETRuntimeDistribution-Versions9.1to12.0

Note:

[1215826|https://www.sdn.sap.com/irj/servlet/prt/portal/prtroot/com.sap.km.cm.docs/oss_notes_boj/sdn_oss_boj_dev/sap(bD1lbiZjPTAwMQ==)/bc/bsp/spn/scn_bosap/notes%7B6163636573733d36393736354636443646363436353344333933393338323636393736354637333631373036453646373436353733354636453735364436323635373233443330333033303331333233313335333833323336%7D.do]

Hope it helps!