cancel
Showing results forΒ 
Search instead forΒ 
Did you mean:Β 

Deploy Fiori Freestyle App to Cloud Foundry - Application missing?!

camichel
Participant
0 Kudos
1,483

Hey together,

i wanted to get familiar with BAS and the deployment to the cloud foundry...

I want to have the Fiori Freestyle App as a standalone app without Launchpad running on the CF...

When I now create a simple app with the wizard in the BAS and build the mta.file and deploy the archive...i got an error when opening the url through the cf html5-list...

Also I got no application in the cf space... which i got former on the WEB-IDE?!

Is there something else I need to setup? Actually I am not quite sure what is missing!

Thanks πŸ™‚

Carsten

camichel
Participant
0 Kudos

Any other in the round got some ideas or other way to deploy an ui5 application from BAS into CF?

Accepted Solutions (0)

Answers (2)

Answers (2)

mariusobert
Developer Advocate
Developer Advocate

You get this error message when you want to access an app via the managed approuter AND haven't subscribed to the launchpad or portal subscription.

If you use the managed approuter, that also explains why you don't see the app in CF (because it's just a web app).

If you want to use the "standalone approuter", you need to select this option in the wizard during the project creation.

camichel
Participant
0 Kudos

mariusobert Thanks πŸ™‚

I wanted to try this but at the Deploy Section in the Wizard...

For Standalone I need to select no there, right?

My steps in the Wizard were Fiori Application --> Freestyle --> SAP UI5 Application...

Is there anything else I need to check before builduing and deploying to the CF?

Edit: I now just did the steps as described above and now NO application was created... Just the html5 Repo...

I think I do something wrong 😞

mariusobert
Developer Advocate
Developer Advocate
0 Kudos

I think you are using the wrong flow. Have a look at this video which explains the longer flow (create empty MTA, add managed approuter, add Fiori app). In your case, you need to select the standalone approuter instead of the managed one.

camichel
Participant
0 Kudos

mariusobert it seems that i do something wrong...

Watched the Video and i choosed standalone...(create empty MTA, Add standalone approuter (no Launchpad or Portal Service yet) and then add freestyle fiori app...

When I then try to build the MTA i got the following error...

info builder:builder application project1 πŸ”¨ (12/12) Running task ui5-task-zipper...
info builder:builder Build succeeded in 507 ms
info builder:builder Executing cleanup tasks...
[2021-05-10 12:17:18]  INFO finished building the "project1" module
[2021-05-10 12:17:18]  INFO building the "test123_ui_deployer" module...
[2021-05-10 12:17:18]  INFO copying files matching the [project1.zip,...] patterns from the "/home/user/projects/test123/project1/dist" folder to the "/home/user/projects/test123/resources" folder
[2021-05-10 12:17:18]  INFO the "/home/user/projects/test123/resources" folder has been created
[2021-05-10 12:17:18]  INFO copying the "project1.zip" pattern from the "/home/user/projects/test123/project1/dist" folder to the "/home/user/projects/test123/resources" folder
[2021-05-10 12:17:18]  INFO the build results of the "test123_ui_deployer" module will be packaged and saved in the "/home/user/projects/test123/.test123_mta_build_tmp/test123_ui_deployer" folder
[2021-05-10 12:17:20] ERROR could not package the "test123_ui_deployer" module when archiving: could not read the "/home/user/projects/test123/project1/node_modules/.bin/detect-libc" symbolic link: stat /home/user/projects/test123/project1/node_modules/detect-libc/bin/detect-libc.js: no such file or directory
make: *** [Makefile_20210510121704.mta:37: test123_ui_deployer] Error 1
Error: could not build the MTA project: could not execute the "make -f Makefile_20210510121704.mta p=cf mtar= strict=true mode=" command: exit status 2


Terminal will be reused by tasks. 

Any Idea what I am doing wrong in my steps to create a fiori app running standalone on the cloud foundry?

mariusobert
Developer Advocate
Developer Advocate

Yes, that's a different issue with the wizard. I described a workaround in this question here

camichel
Participant
0 Kudos

mariusobert one last question...

So the workflow for the Standalone UI5 App on the Cloud Foundry is the following...(Correct me if I am wrong)

  1. Start from Template (Basic MTA) & Choose project name...
  2. Right Click on mta.yaml & create mta module from template
  3. Choose Approuter Configuration --> Standalone Approuter and Yes for the UI
  4. Right Click on mta.yaml & create mta module from template
  5. Choose SAP Fiori Application & choose application type and setting your app...Also add deployment config to mta yaml?!
  6. Add "build-result: resources" to *_ui_deployer
  7. Build MTA & Deploy?

Now to the part where i get the final url of the application in the cloud foundry?

When i click on xyz-approuter in the CF and want to click that link I got an internal error?!

Also where can I adjust the name of the URL?!

Thanks!!

mariusobert
Developer Advocate
Developer Advocate
0 Kudos

Yes, these are the right steps.

I'm not sure why you get an internal error. This could be caused by a broken route or destination. You probably need to check out the log of the approuter to find more hints.

Regarding the URL, you can use the host property in the mta.yaml to change the first segment of the URL. In case you want to use your own TLD, you need to use the custom domains service. You can find more details here in this post that I recently published.

fioriexpert
Explorer
0 Kudos

Hi @mariusobert ,

Thanks for the detailed steps.
I have the same requirement to develop a Fiori app with a standalone approuter and consume a remote CAP OData service in it. I followed your video and was able to create the desired results but I am not able to understand why 2 xs-app.json file gets created - 1 inside the app router folder and the other inside the Fiori app folder. Also, how does these 2 files work together. Can you please help understand this. 

Thanks

priteshpatel65
Active Participant
0 Kudos

hello camichel

I am also get this type of error. if you want to see deployed link or app than just go to

SAP BTP Cockpit and select html 5 application. In this you see that deployed application list, select any deployed app.