cancel
Showing results for 
Search instead for 
Did you mean: 

Decimal separator as comma(,) for numbers in WebI4.3 report

vishal_p3
Participant
0 Kudos
224

Hello Experts,

I have a cross table in Webi4.3 document BEx query as the source and I wanted to change the decimal separator from full stop(.) to comma (,) and did the below 3 settings but no luck. Please suggest if I need to perform any other?

  • a) Control panel -> region -> Additional settings-> Decimal symbol = , and save 
  • b) BI launch pad -> settings -> Application preferences -> Webi -> Select "Use my preferred viewing locale to format the data"
  • c) In BW system, the user's default settings are to get changed in BW system(su01) as shown below vishal_p3_0-1717742254253.png
View Entire Topic
amitrathi239
Active Contributor
0 Kudos

If data type is string and try with replace() function to replace full stop to comma.

vishal_p3
Participant
0 Kudos
Hi Amit, the datatype is integer not a string and hence is throwing error when applying replace() function.