Showing results for 
Search instead for 
Did you mean: 

Decimal Conflict

Former Member
0 Kudos


I have 2 similar queries. They both have 2 structures, one is key fig and other is periods. They use same period structure, key fig structure is not same but very similar.

Requirement is, for spesific periods, i need a key figure to be 0 decimal, when for other periods it is 1 decimal. It is easy to apply:

-i ve changed decimal property of that period as 0 decimal,

-from advanced tab of that "periods" properties, eliminated formula collisiion, "use result of this formula"

I ve applied this in both queries: weird thing is, when it is working well in one, it is not working in other.Still showing 1 decimal, as changes have not been applied. I ve checked every single formula that can cause that difference between them, but no luck.

Also i ve tried to change the problematic cells via cell reference, and it worked. But i want to fix that without cell solution, can anyone recommend anything to check?

Thanks in advance,

Accepted Solutions (1)

Accepted Solutions (1)

0 Kudos


the cause of your problem might be the so-called "priority"-rule. This is desribed in the online doc:


(under: Settings for the Properties of Structure Elements)

When a structure element of the ROW-structure gets a scaling factor of 1000 and a structure element of the COLUMN-structure gets a scaling factor of 10, a cell results in which the two settings collide. In this cell, the system has to decide which of the two scaling factors, for the row (1000) or the column (10) is displayed.

-> The last-changed setting is the one used in the query. This also applies for decimal-places.

Hope this helps.

best regards,


Former Member
0 Kudos

Thanks Jerome,

Your reply anwers my question completely, at least now i know there s nothing i ve missed to check.

OSS no: 568630 has a better explanation of this issue and more.


Answers (0)