cancel
Showing results for 
Search instead for 
Did you mean: 

DDIC Activation looping

Former Member
0 Kudos

Hi All,

I got a fresh vanilla NW 731 Dual Stack install on Windows/Oracle.

It currently sits at SP 00 and I've downloaded my stack to upgrade it via MOPZ to target stack SP10

I Started out using SUM. This tool was freezing and failing. After 3 days I decided to try to implement the ABAP stack via SPAM.

Updated my SPAM/SAINT to ver 051.

I have the latest 720_ext kernel. I have the leatest R3trans, Load and so on.

Twice now I have reached this state and I have done a restore.

It appears during the DDIC Activation Phase, its looping.

Log file:

Here is the error I keep getting and then it appears to start over each time.

1 ED0301X*************************************************************************

1 ED0306       "Calculation of Dependencies:"

1 ED0322 End phase  "003" ***********************************************************

1 ED0320XStart phase "004" **********************************************************

1 ED0306       "Object Activation"

1 ED0301 *************************************************************************

1 EDO533X*** Activate objects at level "1"

3 EDO631 * Parallel execution with maximal "4" concurrent tasks *

3 EDO677 Total of "10.157" objects with &3"5.204.310" costs in &2"41" tasks

2WEDO644X"08:47:31" <- task "00008" receiving error ["SD01CUDB0105_OT4_00"] "(12 Sek)"

2WEDO641             RC="2": "Whole number overflow on addition"" "

3 ED0349             Objects: "DTEL SX_USER" - "TABL /BDL/RSFDO3"

2WEDO644 "08:48:31" <- task "00029" receiving error ["SD01CUDB0105_OT4_00"] "(3 Sek)"

2WEDO641             RC="2": "Whole number overflow on addition"" "

3 ED0349             Objects: "TABL SAML2_CERTIFICATE_S" - "TABL SELECTEDROW"

2WEDO644 "08:48:56" <- task "00029" receiving error ["SD01CUDB0105_OT4_00"] "(2 Sek)"

2WEDO641             RC="2": "Whole number overflow on addition"" "

3 ED0349             Objects: "TABL SAML2_CERTIFICATE_S" - "TABL SELECTEDROW"

2WEDO644 "08:49:05" <- task "00008" receiving error ["SD01CUDB0105_OT4_00"] "(11 Sek)"

2WEDO641             RC="2": "Whole number overflow on addition"" "

3 ED0349             Objects: "DTEL SX_USER" - "TABL /BDL/RSFDO3"

3 EDO645 "08:49:05" <> task "00008" started synchronously ["SD01CUDB0105"] "(378 Obj, 150.700 Cost)"

1 ED0317XProgram start============================================================

1 ED0314

1 ED0314 Mass Activation

Other messages that show its repeating

1 EDO534XObject "LANG" "DTED" "*" was already activated

1 EDO534 Object "LANG" "DTED" "*" was already activated

1 EDO534 Object "LANG" "DTED" "*" was already activated

1 EDO534 Object "LANG" "DTED" "*" was already activated

1 EDO534 Object "LANG" "DTED" "*" was already activated

1 EDO534 Object "LANG" "DTED" "*" was already activated

1 EDO534 Object "LANG" "DTED" "*" was already activated

1 EDO534 Object "LANG" "DTED" "*" was already activated

1 EDO534 Object "LANG" "DTED" "*" was already activated

1 EDO534 Object "LANG" "DTED" "*" was already activated

1 EDO534 Object "LANG" "DTED" "*" was already activated

1 EDO534 Object "LANG" "DTED" "*" was already activated

1 EDO534 Object "LANG" "DTED" "*" was already activated

1 EDO534 Object "LANG" "DTED" "*" was already activated

1 EDO534 Object "LANG" "DTED" "*" was already activated

1 EDO534 Object "LANG" "DTED" "*" was already activated

1 EDO534 Object "LANG" "DTED" "*" was already activated

Anyone have an idea?

Im about to shut it down again.

I attached a TXT document of the log as 1 example the loop

Accepted Solutions (1)

Accepted Solutions (1)

Reagan
Advisor
Advisor
0 Kudos

Hello

Check whether the system is throwing the dumps COMPUTE_INT_PLUS_OVERFLOW

If yes you are hitting the issue mentioned in this SAP Note:

1678047 - COMPUTE_INT_PLUS_OVERFLOW during activation

Call Tx SE38 - SDB1FHDB

Select Source Code and Display

Switch to edit mode and replace:

limit-secindcnt = 2147483647.

with

limit-secindcnt = 1023.

You will need an object key to do this.

Good Luck

Cheers

RB

Ref: http://scn.sap.com/thread/3323740

Former Member
0 Kudos

Update:

I did a full whole DB Restore.

Turned off Archive log

Set my rdisp/max_wprun_time to 18000

Put in Note 1678047

Released it and a couple of other notes

Deleted my Buffer at the OS level

Cleared my TP logs at the OS level

Cleaned my DIR Trans

Updated my SPAM/SAINT to 051

Ran A stats job ( I seen some errors complaining that a table was bigger or smaller than in the file)

And kicked it off again. Only implementing SAP_ABAP and SAP_Basis as test.

Former Member
0 Kudos

I've made it past DDIC_ACTIVATION.

I'm now at the IMPORT_PROPER phase.

My last log write was 1 hour ago.

The CPU and processes on my server are basically at idle..nothing running.

SM50 I see nothing but myself.

Should I be concerned? Anywhere else I could check to see some activity?

Reagan
Advisor
Advisor
0 Kudos

Check the logs first in the /usr/sap/trans/tmp and then /usr/sap/trans/log directories.

The logs for the present phase or action is created in the tmp and once the task is done moved to the log location.

Regards

RB

Former Member
0 Kudos

RB, thats where Ive been monitoring..my last log file has this at the end

4 ETW000 child process 9792 - objects from 136167 to 142075 successfully imported (date&time: 13.12.2013 - 12:50:29)

Nothing has happened in 1 hour....im concerned its hung again.

Former Member
0 Kudos

I believe an old trick is to end the process of R3trans at the OS level...then I can start the SPAM back over...I've done it in the past...not sure if it was this far into the import.

Reagan
Advisor
Advisor
0 Kudos

Is there any job running in the system ?

use Tx SM37 and check for the active jobs.

I wouldn't interrupt the upgrade unless I am sure.

Regards

RB

Former Member
0 Kudos


It crashed on me finally

Category               ABAP Programming Error
Runtime Errors         SYNTAX_ERROR
ABAP Program           SAPLSUU1
Application Component  BC-SEC-USR-ADM
Date and Time          13.12.2013 13:59:51

Short text
     Syntax error in program "SAPLSUU1 ".

What happened?
     Error in the ABAP Application Program

     The current ABAP program "SAPLSPAM" had to be terminated because it has
     come across a statement that unfortunately cannot be executed.

     The following syntax error occurred in program "SAPLSUU1 " in include "LSUU1U09
      " in
     line 237:
     "The type or line type "USRXX_DELETE" cannot be converted to table "USR"
     "07" in the key part cannot be converted to table "USR07" in the key pa"
     "rt,"
     " "

     The include has been created and last changed by:
     Created by: "SAP "
     Last changed by: "SAP "
     Error in the ABAP Application Program

     The current ABAP program "SAPLSPAM" had to be terminated because it has
     come across a statement that unfortunately cannot be executed.

Error analysis
     The following syntax error was found in the program SAPLSUU1 :
     "The type or line type "USRXX_DELETE" cannot be converted to table "USR"
     "07" in the key part cannot be converted to table "USR07" in the key pa"
     "rt,"
     " "

Trigger Location of Runtime Error
     Program                                 SAPLSPAM
     Include                                 LSPAMF01
     Row                                     621
     Module type                             (FORM)
     Module Name                             CHECK_DDIC_USER

Reagan
Advisor
Advisor
0 Kudos

Open a command prompt and connect to the database and run these SQL statements.

select ACTIVE from SAPSR3.PATCHECK where CHECK_NAME='DDIC_USER_REQ';

update SAPSR3.PATCHECK set ACTIVE=' ' where CHECK_NAME='DDIC_USER_REQ';

commit;

Check the solution I have provided here:

SPAM SYNTAX_ERROR | SCN

Regards

RB

Former Member
0 Kudos


Oss Note 1597765

  • SAPKB73105

           Symptom: If the import of the Support Package SAPKB73105 terminates in the phase IMPORT_PROPER, it cannot be continued in the Support Package Manager because this leads to a syntax error in SAPLSUU1:
The row type from "USRXX_DELETE" cannot be converted to the table "USR07" in the key part.

Solution: To avoid the error, the DDIC user check can be deactivated in the settings of the Support Package Manager (option "Check for active DDIC user"). This is possible as of SPAM/SAINT Version 0043.
If the error has already occurred, the deactivation can take place only in the configuration table PATCHECK.  For the entries with CHECK_NAME = "DDIC_USER_REQ", set the value of the field ACTIVE to " " (space/blank character). Then you can continue importing the Support Package queue.
After you import the Support Package queue, you can activate the check again in the settings.

Former Member
0 Kudos

Fixed the issue:

in the SPAM screen, Goto -> Settings

Deactivate Check for active DDIC user. That will resolve the issue


Reagan
Advisor
Advisor
0 Kudos

Which is another way to update the above table.

Regards

RB

Former Member
0 Kudos

Its now at the import proper phase, seems to be frozen again on patch kb73102.

This Patch has 10 child processes, all 9 have ended but this last one seems hung...

First line

4 ETW000 child process 6568 - now importing the objects from 017782 to 017831 (date&time: 16.12.2013 - 09:17:47)

now its sitting here hung, Last line in the log.

4 ETW000   0 entries from TFTIT (1TREX_EXT_PE_COPY              ) deleted.


Any advice?

Reagan
Advisor
Advisor
0 Kudos

What does the import log say ?

Things to check:

/usr/sap/trans/tmp and /usr/sap/trans/log locations

Database logs.

Dumps in the system

Background job status.

Regards

RB

Former Member
0 Kudos

No Background jobs running.

No Dumps in the system

Never checked DB logs.

in my USR\SAP\TRANS\LOG my log file for KB73101 was 403 megs.....

in my USR\SAP\TRANS\TMP... the current log file for KB73102 is 358 Megs..

Maybe it needs more time..

But that file the last line written is:

4 ETW000 waiting for the childrens' results (date&time: 16.12.2013 - 09:17:42)

And this child job is still running

4 ETW000 child process 6568 - now importing the objects from 017782 to 017831 (date&time: 16.12.2013 - 09:17:47)

And this one

4 ETW000 child process 10100 - now importing the objects from 000000 to 017774 (date&time: 16.12.2013 - 09:17:45)

So these 2 child processes seem to have hung my KB73102 patch

Last couple of lines of the 10100 Process:

4 ETW000   0 d /   0 i /   0 u /  18 = 100% ucf D020T

4 ETW000  18 entries for D020T imported (SAPLSTRD                                *).

4 ETW000  61 entries for D020T rejected - language not installed (SAPLSTRD                                *).

4 ETW000   0 d /   0 i /   0 u /  27 = 100% ucf D021T

4 ETW000  27 entries for D021T imported (SAPLSTRD                                *).

4 ETW000 149 entries for D021T rejected - language not installed (SAPLSTRD                                *).

4 ETW000   0 d /   0 i /   1 u /   0 =   0% ucf EUDB

4 ETW000   1 entry for EUDB imported (CUSAPLSTRD                                *).

4 ETW000   0 d /   2 i /   1 u / 153 =  98% ucf RSMPTEXTS

4 ETW000 156 entries for RSMPTEXTS imported (SAPLSTRD                                *).

4 ETW000 853 entries for RSMPTEXTS rejected - language not installed (SAPLSTRD                                *).

4 ETW000  11 d /   0 i /   0 u /  11 =  50% ucf D347T

4 ETW000  11 entries for D347T imported (SAPLSTRD                                *).

4 ETW000 CUALOAD 'SAPLSTRD                                ' successfully removed and corresponding buffers synchronized

Last few lines of the 6568 child process:

4 ETW000   0 entries from TFTIT (9TREX_EXT_PE_COPY              ) deleted.

4 ETW000   0 entries from TFTIT (8TREX_EXT_PE_COPY              ) deleted.

4 ETW000   0 entries from TFTIT (6TREX_EXT_PE_COPY              ) deleted.

4 ETW000   0 entries from TFTIT (5TREX_EXT_PE_COPY              ) deleted.

4 ETW000   0 entries from TFTIT (4TREX_EXT_PE_COPY              ) deleted.

4 ETW000   0 entries from TFTIT (3TREX_EXT_PE_COPY              ) deleted.

4 ETW000   0 entries from TFTIT (2TREX_EXT_PE_COPY              ) deleted.

4 ETW000   0 entries from TFTIT (1TREX_EXT_PE_COPY              ) deleted.

So these 2 child processes havent moved in hours.

Reagan
Advisor
Advisor
0 Kudos

For me it is running.

I would wait for some more time.

As you are updating the stack to patch level 10 then the patching process is going to take a long time.

Regards

RB

Former Member
0 Kudos


Do you think tis note is my issue?

http://service.sap.com/sap/support/notes/1635605

Reagan
Advisor
Advisor
0 Kudos

I thought about this SAP note.

But as this is a newly installed system I believe you must be having the patch level and the SBP above the affected patch levels.

Regards

RB

Former Member
0 Kudos

Yes I am above those levels...I'm letting it go and will monitor.


Reagan
Advisor
Advisor
0 Kudos

Check this SAP note as it provides an SQL query to find out the inactive sessions

1738989 - Upgrade/Support Package import hang due to INACTIVE wait event "SQL*Net break/reset client...

Regards

RB

Former Member
0 Kudos


       273 ACTIVE   9908                     DIAG idle wait
UNKNOWN
ORACLE.EXE (DIA0)

       172 ACTIVE   8948                     Streams AQ: waiting for time m
UNKNOWN
                 Streams
ORACLE.EXE (Q001)

         1 ACTIVE   9812                     rdbms ipc message
UNKNOWN
ORACLE.EXE (MMON)

       410 ACTIVE   9580                     rdbms ipc message
UNKNOWN
                 KTSJ
ORACLE.EXE (SMCO)

       511 ACTIVE   9808                     rdbms ipc message
UNKNOWN
ORACLE.EXE (RECO)

        35 ACTIVE   9816                     rdbms ipc message
UNKNOWN
ORACLE.EXE (MMNL)

       205 ACTIVE   9900                     DIAG idle wait
UNKNOWN
ORACLE.EXE (DIAG)

       375 ACTIVE   9916                     rdbms ipc message
UNKNOWN
ORACLE.EXE (DBW1)

        69 ACTIVE   7836                     pmon timer
UNKNOWN
ORACLE.EXE (PMON)

       307 ACTIVE   9680                     rdbms ipc message
UNKNOWN
ORACLE.EXE (MMAN)

       477 ACTIVE   9804                     smon timer
UNKNOWN
ORACLE.EXE (SMON)

       239 ACTIVE   9904                     rdbms ipc message
UNKNOWN
ORACLE.EXE (DBRM)

       103 ACTIVE   5136                     rdbms ipc message
UNKNOWN
ORACLE.EXE (PSP0)

       104 ACTIVE   1224                     Streams AQ: qmn coordinator id
UNKNOWN
                 Streams
ORACLE.EXE (QMNC)

       444 ACTIVE   9928                     rdbms ipc message
UNKNOWN
ORACLE.EXE (CKPT)

       409 ACTIVE   9924                     rdbms ipc message
UNKNOWN
ORACLE.EXE (LGWR)

       109 ACTIVE   5744                     Space Manager: slave idle wait
UNKNOWN
                 KTSJ
ORACLE.EXE (W006)

       137 ACTIVE   9892                     VKTM Logical Idle Wait
UNKNOWN
ORACLE.EXE (VKTM)

       138 ACTIVE   8944                     Streams AQ: qmn slave idle wai
UNKNOWN
                 Streams
ORACLE.EXE (Q000)

       341 ACTIVE   9912                     rdbms ipc message
UNKNOWN
ORACLE.EXE (DBW0)

        70 ACTIVE   11076:11228              CPU
SELECT S.SID, S.STATUS, S.PROCES
                 sqlplus.exe
sqlplus.exe

       206 INACTIVE 4944:11048               SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

       174 INACTIVE 8456:8464                SQL*Net message from client
UNKNOWN
                 SAPLSFES
disp+work.EXE

       173 INACTIVE 8528:8548                SQL*Net message from client
UNKNOWN
                 CL_SCV_MD_REPOSITORY==========CP
disp+work.EXE

       141 INACTIVE 8504:8524                SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

       140 INACTIVE 4836:11192               SQL*Net message from client
UNKNOWN
                 SAPLSPOA
disp+work.EXE

       107 INACTIVE 8672:8764                SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

       106 INACTIVE 10592:10312              SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

        74 INACTIVE 6280:4688                SQL*Net message from client
UNKNOWN
                 DBSL: con=0, no ABAP
tp.exe

        72 INACTIVE 8440:8448                SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

        71 INACTIVE 8724:8740                SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

        38 INACTIVE 8404:8768                SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

        37 INACTIVE 8560:8512                SQL*Net message from client
UNKNOWN
                 SAPLSPF1
disp+work.EXE

         4 INACTIVE 8476:8396                SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

         3 INACTIVE 4668:4768                SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

       446 INACTIVE 6980:3540                SQL*Net break/reset to client
INSERT INTO "SOTR_HEAD" VALUES(:
                 DBSL: con=0, no ABAP
R3trans.exe

       447 INACTIVE 1234                     SQL*Net message from client
delete from "BC_SYNCLOG" where "
JDBC Thin Client

       207 INACTIVE 8472:8400                SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

       208 INACTIVE 8592:8616                SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

       241 INACTIVE 8660:8552                SQL*Net message from client
UNKNOWN
                 CL_MESSAGE_HELPER=============CP
disp+work.EXE

       242 INACTIVE 8140:10732               SQL*Net message from client
UNKNOWN
                 RDDMNTAB
disp+work.EXE

       243 INACTIVE 8608:8424                SQL*Net message from client
UNKNOWN
                 SAPLCCUS
disp+work.EXE

       274 INACTIVE 8460:8632                SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

       275 INACTIVE 8712:8420                SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

       276 INACTIVE 8588:8612                SQL*Net message from client
UNKNOWN
                 SSFALRTEXP
disp+work.EXE

       308 INACTIVE 8564:8540                SQL*Net message from client
UNKNOWN
                 CL_ABAP_CONV_OUT_CE===========CP
disp+work.EXE

       309 INACTIVE 8628:8648                SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

       310 INACTIVE 6088:8624                SQL*Net message from client

       SID STATUS   PROCESS                  ACTION
---------- -------- ------------------------ -----------------------------------
-------------------------------------------------------
SQLTEXT
                 MODULE
--------------------------------------------------------------------------------
---------------- ---------------------------------------------------------------
-
PROGRAM
----------------------------------------------------------------
UNKNOWN
                 DBSL: con=0, no ABAP
R3trans.exe

       342 INACTIVE 8604:8408                SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

       343 INACTIVE 8480:8492                SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

       376 INACTIVE 8516:8412                SQL*Net message from client
UNKNOWN
                 PFLCHECK
disp+work.EXE

       377 INACTIVE 8428:8600                SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

       411 INACTIVE 8596:8360                SQL*Net message from client
UNKNOWN
                 RDDIMPDP
disp+work.EXE

       443 INACTIVE 8416:8708                SQL*Net message from client
UNKNOWN
                 RSM13000
disp+work.EXE

       445 INACTIVE 8668:8444                SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

       480 INACTIVE 8432:8392                SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

       481 INACTIVE 1234                     SQL*Net message from client
UNKNOWN
JDBC Thin Client

        39 INACTIVE 1234                     SQL*Net message from client
delete from "BC_SYNCLOG" where "
JDBC Thin Client

       513 INACTIVE 8676:8580                SQL*Net message from client
UNKNOWN
                 DBSL: con=0, ai->-1, no ABAP source
disp+work.EXE

       512 INACTIVE 8500:8520                SQL*Net message from client
UNKNOWN
                 CL_SCV_MD_REPOSITORY==========CP
disp+work.EXE


61 rows selected.

SQL>
SQL>
SQL>

Former Member
0 Kudos

6980:3540  INACTIVE SQL*Net break/reset to client  SAPSR3   INSERT INTO "SOTR_HEAD" VALUES(:A0 ,:A1 ,:A2 ,:A3 ,:A4 ,:A5

So It appears I do have that issue even though my patch level is higher.

Do i simply try to put this statement in the initSID.ora file?

_use_zero_copy_io=false

Reagan
Advisor
Advisor
0 Kudos

You are hitting the bug.

I can see the inactive/hanging SQL sessions from R3trans.

Open a command prompt.

sqlplus "/as sysdba"

alter system set _use_zero_copy_io=false scope=spfile;

shutdown immediate;

startup

Start SAP and restart SPAM.

Regards

RB

Former Member
0 Kudos

what am i missing

Former Member
0 Kudos

got it

alter system set "_use_zero_copy_io" = false scope = spfile;

Reagan
Advisor
Advisor
0 Kudos

missed the double quotes " "

Sorry about that.

Good Luck

RB

Former Member
0 Kudos

Now I'm up to SP05...so it is working.

Wow...this was a doozie!

Answers (1)

Answers (1)

Former Member
0 Kudos


I've found some notes

1232775 This one does not relate to my version.

This one might solve my issue.

Note 1678047 - COMPUTE_INT_PLUS_OVERFLOW during activation

Any advice?

Nicolas
Active Contributor
0 Kudos

Hi Joshua,

First of all, SUM is normally used for Enhancement Pack upgrade and not for Support Pack Stack update.

Before applying the note 1678047, did you have the dump described in the note in ST22 ?

Best regards

Former Member
0 Kudos

Like I said, I tried SUM for 3 days and it was crap.

I've decided to try this way since I'm more familiar with it in order to debug. Likely the issue stopping SPAM is the same issue causing SUM to fail.

It never finishes to get a dump. It simply continues to loop until I end the system. Take a look at the attached log file.