cancel
Showing results for 
Search instead for 
Did you mean: 

DB21015E The Command Line Processor error

Former Member
0 Kudos

Hi.

All our DB2 9.1 databases are showing the error "DB21015E The Command Line Processor backend process request queue or input queue was not created within the timeout period" after we changed file /etc/netsvc.conf on all LPARs (AIX virtualized OS) from default blank to contain the entry "local,bind" to ensure that the OS would first look in the local host file before checking addresses at the DNS server. This was done after we experienced major problems with the DNS server itself. This is the only change we are aware of that has been done on the systems before the error occurred.

We've tried to change this value back to default (blank) on one of our systems, but the error still persists.

I've performed the following steps:

db2 terminate

db2stop (this often hangs for a long time, so I've had to kill the processes on OS level)

ipclean (both as sidadm and db2sid)

Then I've tried running the db2iupdt command, but this fails with the following error:

DBI1250E Applications are still using instance db2xq1.

Command ps -ef | grep db2 returns nothing, so no DB2 processes seem to be active. db2diag.log contains the following entry:

INSTANCE: db2xd1 NODE : 000

FUNCTION: DB2 UDB, command line process, clp_start_bp, probe:3

MESSAGE : CLP frontend unable to get REQUEST queue handle

DATA #1 : Hexdump, 4 bytes

0x0FFFFFFFFFFFD4E8 : 870F 0042

Hope you are able to help.

Best regards,

Eivind.

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Hello Eivind,

I'm wondering if this issue could be caused by IPv6 DNS slow resolution. Can you update your netsvc.conf as following:

hosts=local4,bind4

Then, recycle the instance and check if the problem still happens.

Best Regards,

Adam