Showing results for 
Search instead for 
Did you mean: 

DB2 Database Error - SQL0551N - SAPDEV does not have the authorization

Former Member
0 Kudos

Hi gurus, The sap server running on DB2 9.7 FP2 & windows server 2008 64 bit. I have upgrade to EHP4 and it's running successfully. When i try to run the SGEN, after completing 10% it said the tablespace is full. I am aware that during the ECC installation it suppose to be Auto extend mode and i didnt change any setting . now i have this error. Even in St22 abap dump got many error due to this sgen generation (DDIC TYPE INCONSISTENCIES). Then when i check in the DBACOCKPIT, i saw this error message.

@8O\QError message@ DEV SQL0551N "SAPDEV" does not have the required authorization or privilege to perform operation "EXECUTE" on object "SYSPROC.WLM_G

I presume this could be the problem all this issue. However how can i fix this above error message first. can someone guide me through pls. i am just a beginner in DB2 database. Pls provide the steps and solution . Appreciate your help. Thanks.

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

I solved the the above error message in DBAcock pit with this db2 command

db2 grant dbadm on database to user SAPDEV

After executing this command in db2cmd, the error message above doenst appear after i reopen the dbacockpit. I presumed the problem solved.

Former Member
0 Kudos

Hi Guru's,

I am also getting same error.

SQL0551N "DB2HCD" does not have the required

authorization or privilege to perform operation



When I am trying to check the table space it is showing nothing and

throwing these error.

@5C\QRed LED; stop; errors@ HCD An error occurred when processing system HCD

@5C\QRed LED; stop; errors@ HCD Function DB6_HIS_OVERVIEW failed with return code = Other error

Please advice what to do.

Also server is HCD but don't know why object is showing SAPHCP.DBSTATC (HCP is Production server)

Former Member
0 Kudos


Please grant DBADM privileges to schema user SAPHCP. It should solve your problem.


Siva Kumar

Former Member
0 Kudos


this is the correct command after import the data to activate scheema in DBACOCKPIT.