cancel
Showing results for 
Search instead for 
Did you mean: 

Data packet issue with ZVIEW

Former Member
0 Kudos

Dear Experts,

I have created a Z view in R3 sever, In that view nearly 2,55,00,000 records are there. But I need conditional data from the VIEW data.

Material, Plant, Movement type , Posting date are used in CMOD code for the condition.

If Material and Plant is same in our extractor structure and the View and check the (If movement type =101 then sort BUDAT and pick the MAX date Record else movement type =201 agian sort on BUDAT and pick the Max date record is the requirement).

In this case cmode code is working fine and getting max date by checking one material one plant combination in RSA3. But when ever Executing the Info package with same material plant I am getting 2 data packets with 2 records(1 records with max date from 1 data packet and 2nd records with max date from 2nd data packet data).

Here as per my analysis while executing the info package, CMOD code is executing by Packet by packet there by I am getting for each material ,Plant combination more then one record.(based on data packets  its repeating).

I need to get only one record from ZVIEW with 1 material and 1 plant combination. If complete data will coe in one data packet will get resolve my issue but 2 crores of records wants to come under single packet.

Please help on this issue,

Thanks & Regards,

Srinu.Rapolu

Accepted Solutions (0)

Answers (4)

Answers (4)

sander_vanwilligen
Active Contributor
0 Kudos

Hi Srinu,

Can you please confirm if my reply of Dec 26, 2013 6:58 PM is clear?
If not, please let me know how I can help you further.

Thanks,
Sander

sander_vanwilligen
Active Contributor
0 Kudos

Hi Srinu,

In my opinion the combination of view, high data volume and CMOD is not ideal and probably won't work. I would advise to go for an alternative approach: a Function Module extractor.

Here you don't need a view, you can make much more efficient data selections and treat these data selections in a "packaged" way, i.e. you have a much more scalable solution from a data volume perspective.

Best regards,

Sander

KodandaPani_KV
Active Contributor
0 Kudos

Hi Srinu,

Log in ECC sysstementer Tcode- RSCUSTV6

Give number ranges .

Hopes it is help.

Thanks,

Phani.

Former Member
0 Kudos

Hi Pkani,

I have tried that one also from ECC and BW but not resolved.

Please help???

Thanks & Regards,

Srinu.Rapolu

KodandaPani_KV
Active Contributor
0 Kudos

Hi Srinu,

Select your info package--> Scheduler menu -> select Data setting for Default data transfer.

give here how many records transfer to data records each data package.

Please look at screen shot.

Hopes it is helps.

Thanks,

KV.

Former Member
0 Kudos

Hi KV,

In your attached screen shot 5000 records are maximum. for the same in system 20000 records and I am unable to edit more then 20000. please suggest.

Thanks & Regards,

Srinu.Rapolu