cancel
Showing results for 
Search instead for 
Did you mean: 

!! Data not available though I see records in RSA3 !!

Former Member
0 Kudos

BW GURUS !

I am trying to load data into an ODS using 0RPM_PM_01 business content extractor. It is set to full upload.

I see 47 records when I run the extrcator checker on the source system side.

I replicated it, and checked almost everything I can think of.Do you think its a program error.

FYI...this is the first time we are using this extractor

Any thoughts on this.

Best Regards!

Praveen

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

- Yes, the request changed to green in the ODS with "0" records.

-It doesn't give any error msg - It just says no data available.

-Yes, the processing is set to update ODS.It does update th PSA but no records in there too.Alsoit is teh right data target with a full load.

-Nope there is no data in the PSA either.

Regards

Praveen

0 Kudos

hi Praveen,

can check with basis the authorization given to background user (ALEREMOTE?) used to extract data ?

try to grant SAP_ALL and see what happen ?

hope this helps.

Former Member
0 Kudos

Thanks very much guys!

A.H.P - You are right that was something related to security.

Regards!

Praveen

Former Member
0 Kudos

This note came at a perfect time as I was having the same issue. We put SAP_ALL into the remote user and was able to pull the records as expected.

Ongoing, we can't find any documentation as to what specific authorization the remote user should have. Our security guy has tried to figure this out, but hasn't been successful. Any idea what should be assigned to the remote user for this?

Thanks, Keith Johnson

0 Kudos

hi Keith,

normaly use profie S_BI-WX_RFC but the delivered profile may incomplete, there is oss note

150315-BW-Authorizations for Remote-User in BW and OLTP

hope this helps.

Symptom

1) The ALE user fails security in the BW side

2) Missing authorizations when executing Customizing of extractors

3) No IDocs could be sent to the SAP-BW using RFC.

4) Automatic source system connection failes with error R3220: No RFC-Parameters in source system defined

5) When collecting content in BW, warning message RSAOLTP035 comes up

Other terms

Authorizations, SAP_ALL, S_BI-WX_RFC, S_BI-WHM_RFC, S_RS_ALL, ALEREMOTE, BWREMOTE, RSAOLTP 553, RSAOLTP553

Reason and Prerequisites

a) In the BW there exist two user:

i) a human administrator, using S_RS_ALL

ii) a user called BWREMOTE (or similar), used to receive the data

from the OLTP, using S_BI-WHM_RFC

b) In the OLTP there exist also two user:

i) a human administrator, needing authorizations to create users

and RFC-destinations.

ii) a user called ALEREMOTE (or similar), used to ...

1) ... connect the OLTP to the BW

2) ... extract the data

3) ... send the data to the BW

4) ... show monitoring dialogs

for tasks 1 to 4, the profile S_BI-WX_RFC is used (however does

not suffice on some points since some authorizations are

missing in the delivered profile)

........

Answers (1)

Answers (1)

Former Member
0 Kudos

Something's to verify include:

-Did the Scheduled job show success in the monitor, if so did it show 47 records transferred, if not what error was posted?

-In the InfoSource-InfoPackage you ran; is the processing set to update the ODS, does it update the PSA, is there a filter set, is the right data target set, was a full load ran or a delta load?

-Is there data in the associated PSA?

The code is most probably OK but the configuration often needs smoothing.