cancel
Showing results for 
Search instead for 
Did you mean: 

Customising 0ANALYSIS_PATTERN Web Template

former_member483612
Participant
0 Kudos
274

Hello,

I've customised 0ANALYSIS_PATTERN web template by saving it as ZANALYSIS_PATTERN.

I now want to set ZANALYSIS_PATTERN as the default web template for all the BEx Queries executed from BEx Query Designer and also for the Portal iViews for these BEx Queries.

To achieve this I've set 'ZANALYSIS_PATTERN' as standard web template for 'Ad Hoc Analysis' in the transaction 'RSCUSTV27' in BI. However when I execute the BEx Web reports it is still taking '0ANALYSIS_PATTERN' as the web template.

Could someone please suggest what else do I need to do to set 'ZANALYSIS_PATTERN' as the default template for all the reports?

Many thanks.

Regards,

Sri.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Sri, Please have a look at this [link|;. Could you tell us, if you are facing the issue in WAD or BEx Web based Analyzer also? We've a BI Installation Addon 7.X (based on 7.10); Suport Pkg 10; Patch 1; Revision 486 & I'm able to work on WAD using OPEN_VIEW. Just restart the J2EE server for the changes to be reflected. Thanks!

former_member483612
Participant
0 Kudos

Hi Arun,

Its the BEx Web Analyser. After creating query using BEx Query Designer and execute it from there the web report is still using 0ANALYSIS_PATTERN and not ZANALYSIS_PATTERN. Also, we have iViews created for these BEx Queries on the portal. When executing these queries from Portal, it is using 0ANALYSIS_PATTERN.

We do not have any WAD reports.

So, after setting the web template for ad hoc analysis as 'ZANALYSIS_PATTERN' in RSCUSTV27, do we have to restart the J2EE server to reflect the change? Is there any any other step involved?

Many thanks,

Sri.

former_member186696
Active Contributor
0 Kudos

Hello Sri.

Maybe the problem remains on your ivews.

Try the following test:

  • go to RSRT2 transaction.

  • select a query and click on JavaWeb.

If the browser opens teh query with ZANALYSIS_PATTERN, so the ABAP side is ok.

If the browser opens with 0ANALYSIS_PATTERN, there is something missed on your configuration.

Well, I believe the ZANALYSIS_PATTERN will works with my steps.

So, go to your iviews configurations. Probably you will find the statement TEMPLATE=0ANALYSIS_PATTERN&QUERY=

Thanks.

Edward

former_member483612
Participant
0 Kudos

Hello Edward,

Thanks for the response.

I've checked in RSRT2 and the web template it uses is 0ANALYSIS_PATTERN.

I guess I need to get the J2EE server restarted and I've now requested BASIS to do that. I'll update my observations after that.

In the meantime, any other suggestions are welcome...

Many thanks.

Best Regards,

Sri.

former_member483612
Participant
0 Kudos

Hi,

After the restart of the server, the ZANALYSIS_PATTERN has come into effect.

Regards,

Sri.

Answers (0)