cancel
Showing results for 
Search instead for 
Did you mean: 

Customer fields for extraction / 2LIS_17_I0NOTIF

Sm1tje
Active Contributor
0 Kudos
267

Hi all,

table QMEL was extended with about 20 customer fields using an append structure. These customer fields, which are filled in the online transaction IW22, will have to extracted to BW as well. How to do this?

I already extended the structure MC17I0NTF with a new append structure holding the same fields as the append structure of table QMEL. What else do I have to do to make sure these fields are extracted together with the standard fields (for example do I have to do some necessary customizing in transaction LWBE)?

Thanks in advance,

Micky.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Appending the fields is not always enough. First in RSA5 with the edit mode on your extractor check that the new fields are not hidden. Initially new fields are hidden.

If the fields are visible you can check if they are filled via RSA3. If they are not filled you must write your own ABAP to fill the fields.

In RSA5, click on button function enhancement and you can go from there to the user-exit. Let this forum know if you need help with that.

Former Member
0 Kudos

mickey,

if u have appended the structure, then just check whether these fields appear in ur ds? in rsa6 double click on ur ds and make sure that ur hide field option is unchecked. u can see whether these fields are added through tcode rsa3.

how ru filling data to thse new fields ? writing user exit in exit_saplrsap_001. u can check in rsa3 again to see whether those fields are populated with data acoording to ur code logic.

Since its an LO datasource, u need to delete setup tables first, fill them for an initial upload. for ur delta uploads u first need to run a v3 collective job run.

Sm1tje
Active Contributor
0 Kudos

Hi Mahantesh, T. Jans-Beken and Ravi Raj,

with your help I was able to extract the data from R/3 and retrieve the customer fields for extraction using BAdI RSU5_SAPI_BADI. I used parts of your suggestions and it seemd to be working correctly now.

Thanks for your quick replies.

Kind regards,

Micky Oestreich

P.S. Sorry for my late reply, due to circumstances I was out of office.

Answers (1)

Answers (1)

Former Member
0 Kudos

Micky, Fill up the set up table and check all the fields are getting populated or not?.

i guess all fields will get populated.check it and explain me your question clearly.

regs,

mahantesh