cancel
Showing results for 
Search instead for 
Did you mean: 

Custom Zoom problem

Former Member
0 Kudos

Using the Custom Zoom in the Crystal viewer ( CR2008 full version) causes the viewer to lock up.

Does someone have any idea why?

Accepted Solutions (1)

Accepted Solutions (1)

former_member183750
Active Contributor
0 Kudos

What SP for CR 2008 are you on?

What version of .NET?

Please give more info re. "custom zoom". E.g.; how?

Ludek

Follow us on Twitter

http://twitter.com/SAPCRNetSup

Former Member
0 Kudos

Sorry. CR 2008 SP2 full version, VS 2008

When i select the "customize.." options under the zoom the viewer just lock out completely. I have to restart the Application.

It is a windows based applicataion.

former_member183750
Active Contributor
0 Kudos

That works fine for me. I zoomed from 100 -> 150 -> 200% with no issue. Are you able to enter the zoom level or is it stopping as soon as you click "Customize..."?

Since you have SP 2, install FP 2.7 on top, that will get you to the same patch level I am at;

https://smpdl.sap-ag.de/~sapidp/012002523100005755702010E/cr2008fp27.exe

What screen res are you on? What DPI setting do you have? Anything unusual about this computer? E.g.; is it a desktop, laptop, etc.?

Ludek

Former Member
0 Kudos

I have installed the patch and having the same issue.

I am able to select the zoom level but it is stopping as soon as I click "Customize..."

I am using laptop Dell precision m4400 but nothing unusual.

I tested it on other macines and it does not work as well.

former_member183750
Active Contributor
0 Kudos

What screen res are you on? What DPI setting do you have? Also, what OS?

Ludek

Former Member
0 Kudos

1600x1200, 96DPI, windows xp.

former_member183750
Active Contributor
0 Kudos

Putting a break point in your code and stepping through the code may give us some error or warning

[Process Monitor|http://technet.microsoft.com/en-ca/sysinternals/bb896645.aspx] may also help.

Try the sample app crnet_win_simplepreview to see if you can reproduce the issue there. The app can be downloaded from here:

https://wiki.sdn.sap.com/wiki/display/BOBJ/CrystalReportsfor.NETSDK+Samples

Ludek

Former Member
0 Kudos

I downloaded a few win projects and yes the custom zoom is working.

I tried to replace my viewer but not success.

I have no any errors and any wornings. I do not know what else can be done

former_member183750
Active Contributor
0 Kudos

See if deleting the viewer off the form and re-adding it will help. Make sure you are referencing the correct viewer. Yours should be defined in CrystalDecision.Windows version 12.x.

Knowing that an exiting sample app works, what about a new app? One liner will do:

CrystalReportViewer1.ReportSource = "<path to saved data report>"

Ludek

Former Member
0 Kudos

I tried to re-add it. No success. I have all references defined to 12.x.

I think I found what cased it.

the only one diffrent I have is how report is loading.

i try to create selected report object

case "COST1"

objRpt = New Cost1

Custom zoom locks up

when I cange it to:

path= "C:\....\...\Cost1.rpt"

objRpt.Load(path)

CustomZoom works.

do you have any idea why?

former_member183750
Active Contributor
0 Kudos

No idea. I used the crnet_win_simplepreview sample app from here:

https://wiki.sdn.sap.com/wiki/display/BOBJ/CrystalReportsfor.NETSDK+Samples

All the load and view options work in that project. Perhaps if you can post more of your code, I'll be able to see somthing...

Ludek

Former Member
0 Kudos

We moved to CR 2010 beta and still having problem with a custom zoom.

Here is my code

dm objRpt as new crystalDecisions.CrystalReports.Engine.ReportDocument()

Select Case reportname

Case "COST"

objRpt = New Cost1

objRpt.SetDataSource(ds.Tables(0))

CrystalReportViewer2.ReportSource = objRpt

Like i have already mentioned if i change it to:

Case "COST"

path= "C:\....\...\Cost1.rpt"

objRpt.Load(path)

objRpt.SetDataSource(ds.Tables(0))

CrystalReportViewer2.ReportSource = objRpt

i have no any problem with a custom zoom. What i am missing?

former_member183750
Active Contributor
0 Kudos

1) Have you tried the sample app I recommended in my last post?

2) As you are now using CRVS2010, please create a new thread. CRVS2010 is a Beat and is tracked differently that in production versions of CR.

See the sticky post at the top of this forum; [Crystal Reports for Visual Studio 2010 Beta - read before posting|;

Ludek

Former Member
0 Kudos

1. i did and it works but the same solution does not work on my project.

2. Ok, thanks.

former_member183750
Active Contributor
0 Kudos

Unfortunately Oksana, if the sample app works and yours does not, there is little we'll be able to do over the forums (e.g.; it's obviously not the CR product and I suppose you confirmed that by going to CRVS2010). You need to figure out the difference. Creating a phone case will be a very, very good idea here as the phone support tech may be able to determine the differences - though he / she will not recode or modify the project code. That is beyond tech support and encroaches on consulting.

If you do decide to create a phone case, you will have to be on a non Beta, supported product. E.g.; CR XI R2 or CR 2008 (or one of the .NET bundles).

Oh, phone support can be obtained here:

http://store.businessobjects.com/store/bobjamer/en_US/pd/productID.98078100

Ludek

Edited by: Ludek Uher on Jul 29, 2010 9:54 AM

Former Member
0 Kudos

Thank you, Ludek. I will probably go with the phone call

Former Member
0 Kudos

Hi Oskana,

Have you got any solution ? I am facing same problem in VS2010.

sample app report is "Embedded Resource" and my app report is not embedded.

Thanks,

Gaurav

Answers (0)