cancel
Showing results for 
Search instead for 
Did you mean: 

Custom fields not available in the attributes in the Score Builder - SAP Marketing Cloud (2002)

0 Kudos

Hello, everyone,

After I have created custom fields, enabled them for the Score Builder and the Maketing scenario and also published them successfully, I should be able to see and select them among other attributes in the Score Builder and use them for my rule sets. However, I can do this for one custom field. It takes quite a long time until it appears in the Score Builder. But I need more other custom fields that I can use as attributes in the Score Builder for different rule sets. After I create the first custom field and enable it for the Score Builder, I fail with the other fields. I have created and activated them and published them successfully, but they do not appear as attributes in the Score Builder. What could be the error? How can I do this without spending so much time, because it looks like only one custom field can appear in the Score Builder in one day, which is crazy. I am actually running out of time.

Thanks a lot in advance!

KunalBansal
Active Contributor

Hello lorab,

You need to enable view of those attributes in Segmentation Configuration.

  1. Go to path - https://my30xxxx.s4hana.ondemand.com/ui#SegmentationConfiguration-maintain
  2. Open the related Data Source
  3. Find your field and mark Visible as Attribute

Thank you.

Best Regards,

Kunal Bansal

SAP Marketing Consultant

Accepted Solutions (0)

Answers (2)

Answers (2)

0 Kudos

Hello kunalkumar.bansal,

the first screenshot is from Marketing Extensibility -> Assign to Segmentation and the second screenshot is from Marketing Extensibility -> Segmentaton Configuration -> Attribute Visibility.

It's about the field Rentabilitaet-Score, as an example.

Thank you again.

Best regards,

Lora

guipaulino
Active Participant
0 Kudos

Hello lorabregu and kunalkumar.bansal ,

I am facing the same issue. For me, it works in QA tenant. I can view/select/use custom fields in score builder app. However in PRD tenant the custom fields are not visible and we have done all transport settings.

Let me know if you have any clue what this might be.

Br

Guilherme.

guipaulino
Active Participant
0 Kudos

lorabregu ,

I raised a ticket to SAP. They said it might be due to special characters in the 'descriptions' of custom fields. Indeed I had special characters in my custom fields however I have changed that but still doesn't work. Maybe you can try that out.

Will update you if SAP replies anything furthers.

BR

Guilherme.

former_member679901
Discoverer
0 Kudos

Hello @kunalkumar.bansal,

Thank you for your answer.

I have done it and still nothing, unfortunately. It's been more than 2 days now, and I still can't see any of my custom fields in the Score Builder.

Best regards,

Lora

KunalBansal
Active Contributor

Hello lorab,

Can you share the screenshots of your configuration?

Please hide the sensitive data in screenshot!

best regards,

Kunal