cancel
Showing results for 
Search instead for 
Did you mean: 

Crystal reports for VS2017 wont display any record

0 Kudos

I have VS 2017 community edition, v15.9.15 and installed CRforVS13SP25_0-10010309.EXE.

When I try to run a query/view from SQL server 2014, it doesn't show any records at all. Just displays the header text. Whereas a datagridview is displaying all the records.

Tried this code:

Private Sub Form1_Load(sender As Object, e As EventArgs) Handles MyBase.Load
'TODO: This line of code loads data into the 'NorthwindDataSet.Current_Product_List' table. You can move, or remove it, as needed.
Me.Current_Product_ListTableAdapter.Fill(Me.NorthwindDataSet.Current_Product_List) Me.CrystalReport11.FileName = "c:\temp\ExcelCrystalRpt\ExcelCrystalRpt\CrystalReport1.rpt"
Me.CrystalReport11.Refresh()
Me.CrystalReportViewer1.RefreshReport()
Me.CrystalReportViewer1.Refresh()
End Sub

But still no records. What I am doing wrong.

Accepted Solutions (1)

Accepted Solutions (1)

DellSC
Active Contributor
0 Kudos

Are you trying to load the dataset from the application into the report or are you trying to run the report directly against the database? I don't see where you might be connecting the report to a dataset.

If you want to load the dataset from your app into the report, you can see https://archive.sap.com/documents/docs/DOC-33869 for some additional information and links to sample code.

If your report is connecting to the database instead of using the ADO dataset from the app, see https://blogs.sap.com/2016/02/17/how-to-parameters-in-crystal-reports-for-visual-studio-net/ for sample code showing how to do this.

-Dell

Answers (1)

Answers (1)

0 Kudos

Don't Refresh, that defaults to use the object info when you open the report.