cancel
Showing results for 
Search instead for 
Did you mean: 

Crystal Reports 2020 SP03 doesn't save suppress formula (bug)

patrick_simons2
Participant

Hi,

CR2020 SP03 does no longer save the suppress-formula of f.ex. a new text object. If you write a formula and save it, the button becomes red:

Close the format editor and reopen it, the suppress formula disappeared (x-2 no longer red).

Repro:

  • open a blank report from scratch
  • insert a text object
  • open the formula editor of that text object and edit the suppress formula - f.ex. 1=2
  • "save and close"
  • Close the formula editor window
  • reopen it, the formula is no long there

If ever you check the suppress checkbox the formula will remain saved, even if you uncheck the checkbox afterwards.

This happens only with SP03, also with patch 100. SP02 doesn't have this problem.

Regards,

Patrick

Accepted Solutions (0)

Answers (10)

Answers (10)

DonWilliams
Active Contributor

It's been fixed:

3315543 - Suppress formula does not save in Crystal reports 2020 SP03

Check with R&D when the fix will be released

DonWilliams
Active Contributor

Hi Patrick,

I am retired now but I did let the guys know, R&D could reproduce the issue so waiting for someone in Support to create a case and escalate to Dev.

I was just about to update you with this info but you beat me to it...

Have a great day

Don

patrick_simons2
Participant
0 Kudos

Update: the fix has been release in CR 2020 SP03 Patch 200.

patrick_simons2
Participant
0 Kudos

Hi Don,

Perhaps you can ask R&D that they update this thread here if they have any news...

DonWilliams
Active Contributor
0 Kudos

Nice find Chester...

FYI - The issue has been escalated to R&D for a fix, sorry I don't know the KBA that reports this, nor do I know what patch the fix will be released in... Now that I'm retired I don't have access to create KBA's nor search for them...

chester_hamilton50
Discoverer
0 Kudos

For anyone else who may run into this, I was playing with permutations to find a way to get the formula suppression edits to save and I finally found a workaround until they fix this bug:

What you can do is edit some other normal formula in your report, let's say for one of your textboxes, and this will launch the formula editor. Then scroll down the left hand side to the graphic objects that would be under "formatting formulas". Locate your suppression formula and then make your edits and then save and then it will save.

The bug itself seems to be related to launching the formatting formula editor directly from the image properties UI but it would seem if you browse to find that same formatting formula through other means then when you make an edit it will actually save.

I was sweating bullets on this as I had a major report upgrade to complete for production release so I'm glad I finally found a way around this problem, hopefully anyone else who runs into this can benefit from this finding as well.

chester_hamilton50
Discoverer
0 Kudos

Yes I am a long time user and customer and I am also experiencing this problem very much to my chagrin.

We use a fair bit of image suppression logic via the formula but now they cannot be edited and saved so this really needs to be escalated as it's a significant bug for a production report writer system.

DonWilliams
Active Contributor
0 Kudos

Hi Patrick,

I'm still here in Community only, no cases now...

I don't know who is going to focus on .NET now, it's going to be a shared process and likely no one is going to watch the community.... except me...

Have a great day

Don

patrick_simons2
Participant
0 Kudos

Hi Don,

Lucky you, I'm happy for you, but sad that a competent engineer will be missing in these forums 😉 Thank you for all these years of support. Btw. do you have a name of your successor for your topics for me (CRVS...)?

For the bug, will I get a response here in this post from R&D/Dev when it will be fixed?

Patrick

patrick_simons2
Participant
0 Kudos

don.williams could you take a look?