cancel
Showing results for 
Search instead for 
Did you mean: 

Crystal Report Viewer is not appearing after hosting on server

Former Member
0 Kudos

Dear Friends

I developed a web application in Visual Studio 2010, and my Database is SQL Server 2008 R2.

I created reports using Crystal Report 13 in Visual Studio and my Operating System is Windows 7 32-Bit.

All reports are running fine at my machine.

When I copied published folder into "wwwroot" folder and hosted, all reports are working Good.

Here i have my web application in "Default Web Sites" in IIS.

Then After I added a new website in IIS with a port No. and created a virtual folder and hosted my web application.

The application is running fine, But the problem is Reports are not appearing on Web Page.

I have created an toolbar to export the report. And when I am exporting the report to PDF, It is working well and reports are exported successfully.

I didn't understand why this is happening?

Is this a problem of port no. ?

or

Is this a problem of IIS?

or

Is this a problem of Browser?

or

Is this a problem with CrystalReportViewer?

or

something else?

In fact I have the folder for "C:\inetpub\wwwroot\aspnet_client\system_web\4_0_30319\crystalreportviewers13". for crystal reports.

Dear All kindly help me in this issue, it is disturbing me since 5 days.

All helps are appreciable.

Thank you.

Accepted Solutions (1)

Accepted Solutions (1)

former_member183750
Active Contributor
0 Kudos

Enter the following:

viewer blank net crystal

into the search box in the top right corner. You should get a number of hits (Kbases and articles) that should point you to a solution.

Ludek

Follow us on Twitter http://twitter.com/SAPCRNetSup

Got Enhancement ideas? Try the [SAP Idea Place|https://ideas.sap.com/community/products_and_solutions/crystalreports]

Answers (0)