cancel
Showing results for 
Search instead for 
Did you mean: 

Crystal Report prompted multiple times for same SQL Command parameters

Former Member
0 Kudos

Post Author: jenxia

CA Forum: General

Hi,

I am working on Crystal Report XI, CR Developer with Product Version 11.0.0.2592.

I have few reports generated by Crystal Report XI that has parameters for SQL Commands and paramaters for Selection Formula.

While parameters for Selection Formula only prompted once for user input, the parameters for SQL commands got prompted multiple times by Prompt Engine of Crystal Report, once at Set database connection and then twice at refreshing report data for the identical parameters.

Does any one on these forums have seen this before?

Is there a way to suppress those extra prompts input?

Any suggestion?

Thanks in Advance for any response!

Regards

Jen

Accepted Solutions (0)

Answers (4)

Answers (4)

Former Member
0 Kudos

Post Author: jenxia

CA Forum: General

SQL Command is :

{

SELECT UNIQUE ContactID, incomingAddress,applicationid,

MediaStatus, MediaDirection, EndDateTime, StartDateTime

FROM MMCAContactMediaViewwhere EndDateTime>= {?1-reportstarttime} and EndDateTime <= {?2-reportendtime}

Order by ContactID

}

Select formula using dynamic prompts as

{Command.contactid} = {?ContactID} and{Command.applicationid} = {?ApplicationID} and{Command.incomingaddress} = {?IncomingAddress}

Former Member
0 Kudos

Post Author: V361

CA Forum: General

Sorry about the SP4, must be a 60's flashback... can you copy the SQL out of CR and post it to the forum ?

Former Member
0 Kudos

Post Author: jenxia

CA Forum: General

Hi, V361,

Thank for the respnse!

Actually there is no sub-report in my reports. They have only one report, no chart also.

You are right about that I am not on SP2 yet. I do have all the hotfix provid for CRXI.

I am not sure about SP4, but there is no any fixes related to this on SP2 and SP3.

I has not seen that SP4 get release.

Former Member
0 Kudos

Post Author: V361

CA Forum: General

You may have some sub-reports causing the duplicate requests. If you have sub reports, you can right click them and select change sub-report links, this way you can tie the Sub reports into the main. Also, you are not on the latest Product Version, My quess is you are not even on SP2 yet.... Any how.... Your product version will be 11.5.9.1076 when you get to (CRXI Developer on SP4) You