cancel
Showing results for 
Search instead for 
Did you mean: 

Crystal Report 2008 with Visual studio 2005 deployment problem.

Former Member
0 Kudos

Dear Friends,

I have downloaded the evalauation version of Crystal report 2008.

and changed the code of My .net application from Crystal report 9 to Crystal report 2008.

it is working fine on My machine. But when i uploade this to my Server it is not working.

I have installed Crystal 2008 runtime sp3 on the server together with Crystal report for .net framwork 2.0.

my application is working but when i run the report page it gives the following error.

CS0433: The type 'CrystalDecisions.CrystalReports.Engine.ReportDocument' exists in both 'c:\WINDOWS\assembly\GAC_MSIL\CrystalDecisions.CrystalReports.Engine\12.0.2000.0__692fbea5521e1304\CrystalDecisions.CrystalReports.Engine.dll' and 'c:\WINDOWS\assembly\GAC_MSIL\CrystalDecisions.CrystalReports.Engine\10.2.3600.0__692fbea5521e1304\CrystalDecisions.CrystalReports.Engine.dll'

Before Crystal report 2008 my application was ruuning successfully in Crystal report 9.

Please help me or adbise me how to deploy my applictaion.

Regards,

Ghaiz anwar

Accepted Solutions (1)

Accepted Solutions (1)

former_member183750
Active Contributor
0 Kudos

Moved your thread to the NET - SAP Crystal Reports forum.

Uninstall both versions of the runtime.

Reinstall Crystal 2008 runtime sp3

You do not need the runtime for CR 10.2 (thought is should not matter that both are on the box). But see how things go with just the CR 2008 runtime.

Ludek

Follow us on Twitter http://twitter.com/SAPCRNetSup

Got Enhancement ideas? Try the [SAP Idea Place|https://ideas.sap.com/community/products_and_solutions/crystalreports]

Answers (0)