cancel
Showing results for 
Search instead for 
Did you mean: 

Creating an XS application on the sap hana cloud platform

Former Member
0 Kudos

When I try to create a sap hana xs file in the (jwe) sap hana editor I get the following message:

14:25:52 >> Error while creating application:

Server Error:Repository: User is not authorized to execute specified operation;User 'DEV_8I9ZU03MVT6ALHF6R75D16RD4' has no authorization, privilege: 'REPO.MAINTAIN_NATIVE_PACKAGES', package: '.REPO_PACKAGE_ROOT'!

When i try to create the project in eclipse, although it has created the xs project, i get the following message:

Operation failed

Repository request failed.

Repository: User is not authorized to execute specified operation;User 'DEV_8I9ZU03MVT6ALHF6R75D16RD4' has no authorization, privilege: 'REPO.READ', package: 'hanaxs'!, code: 40.156, argument:

Unsupported encoding Cp1252 for file 'hanaxs:.xsapp', only UTF-8 encoding is supported.

Apply the quick fix to change the encoding settings.

Unsupported encoding Cp1252 for file 'hanaxs.".settings":.jsdtscope', only UTF-8 encoding is supported.

Apply the quick fix to change the encoding settings.

Unsupported encoding Cp1252 for file 'hanaxs:.xsaccess', only UTF-8 encoding is supported.

Apply the quick fix to change the encoding settings.

Unsupported encoding Cp1252 for file 'hanaxs:hanaxs.hdbschema', only UTF-8 encoding is supported.

Apply the quick fix to change the encoding settings.

I do not seem to be the only one, but i failed to find an answer.

Where do i find quick fix?

Can anybody help?

Thanks,

Jean-Marie

Accepted Solutions (0)

Answers (2)

Answers (2)

gowrisankar_m2
Contributor
0 Kudos

Hi sheetansu,

Got it, <shared> HANA schema and Trial Instance (HANA XS) are NOT connected to each other.This is the reason you dont see the package. Please delete the instance firrst, then create the new schema and try creating the new instance and check, it will work

Also did you try via HANA webide ?

BR, Gowrisankar

0 Kudos

Hi Gowrisaankar

I am also getting the similar error .

Not able to see any package in the Studio ( using trail hana cloud instance)even i have create a schema

Not sure about How to connect with the DB

Please help

error 1 : while trying to activate the attribute view i am getting the below error

Former Member
0 Kudos

Hey Jean Marie,

I am also facing same error while creation of XS project .

Could you please share how did you fix this problem?

Thanks

Sheetanshu

gowrisankar_m2
Contributor
0 Kudos

Hi Jean-Marie Piens , Hi sheetanshu,

You are using the wrong directory. this issue will be solved by creating it in right" directory.

Please refer the screenshot, [what ever the name which you given while creating the hana instance, only inside to that package only you have permission. Please create now and let me know]

BR,Gowrisankar

Former Member
0 Kudos

Hi Gourisankar,

Thanks for your reply. I added this new cloud instance to the eclipse 'SAP HANA DEV' prospective. I do not see any package under Content->P***trail. Neither i have any authorization to create one.

Thanks

Sheetanshu