cancel
Showing results for 
Search instead for 
Did you mean: 

Create JCo Destination is disabled

Former Member
0 Kudos

Hi Gurus,

I have logged in as J2EE_ADMIN / SAPUSER to maintain the JCo destinations but i see that all buttons i.e. "Create JCo Connection", "Maintain JCo Connection", "Start Assigned SLD" are disabled. Only "Check SLD connection" is enabled Because of this I am not able to maintain the JCo destinations. Can you please advice me how to enable this all so that i can create and test JCo connections.

I tried changing the values in Visual Administrator.

Firstly,I found that only 3 tabs are provied there .i.e. Information, HTTP Setting and CIM Client Generation Setting. I could not find RFC Settings tab.

Secondly, When i tried to check "CIMClient Test" , it came with an error message "Failed to generate and test CIMOMClient Object". Please let me know how to resolve this error. Below are my settings. Pease do let me know if i have to correct anyone :

Settings at Visual Administrator : Execute go.bat

====================================

1) Login Screen :

-


User Name - J2EE_ADMIN

Host - gcecc6.ajay.com

Port - 50004

Connect - Default

2) HTTP Settings Tab:

-


Host - gcecc6

Port - 50000

User - SLDDSUSER

3) CIM Client Generation Settings Tab

-


Host - gcecc6

Port - 50000

User - J2EE_ADMIN

Here When i tried to check "CIMClient Test" , it came with an error message "Failed to generate and test CIMOMClient Object". Please let me know how to resolve this error.

I found that only 3 tabs are provied there .i.e. Information, HTTP Setting and CIM Client Generation Setting. I could not find RFC Settings tab. Is there any setting to enable it.

Settings at Portal End

=======================

SLD URL : http://gcecc6:50000/sld

Technical settings --> Profile . Here i set below settings:

1) Data Supplier:

-


Gateway Host - localhost

Gateway service - sapgw00

2) Server Settings

-


Object Server - gcecc6

Settings at SAP End : Tcode RZ70

====================

Host - gcecc6

Service - sapgw00

Also i am not sure how the data flows between Visual Administration, SAP system and Portal. So please let me know if i have to start/stop SLD in portal, import / export any data.

Thanks in advance..

Ajay

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Ajay,

Is your SLD located locally on the J2EE server? In our case the SLD is on our Solution Manager system and I had to configure the connection in the Visual Administrator first.

Open the Visual Administrator and navigate to Server -> Services -> SLD Data Supplier. Then, click on the http tab and input the host, port, slddsuser ID and password. Click save and this should connect you to the SLD. After that, you can maintain your JCo Destinations.

Please let me know if this helps.

Regards,

Rick

Former Member
0 Kudos

Hello,

Check whether the userid/password is correct and the user is not locked.

Regards

Deb

Former Member
0 Kudos

Hi Debasis,

Where can i check that this User is locked or not. I do feel that in my settings for Data Suppliers, Gateway host is set as "localhost". Should i change this to "gcecc6" and then i stop my SLD and restart it again ?

Thanks in advance

Ajay

Former Member
0 Kudos

go to SU01 tcode and check whether SLDuser is locked or not.if yes unlock it and change the gateway host to gcecc6 and then check

reward points if helpful

Former Member
0 Kudos

please try to contact portal developers if they have some buttons/themes that have to be imported/set in visual administrator. It happened once for me. After i set the theme to the correct one, the buttons maintain jco destinations/check sld etc were available.

the path to set the theme in visual administator is

server>services>configuration adapter>webdynpro>sap.com>tcwddispwda. Double click on Property sheet default.

note-Switch to change mode by clicking on the pencil icon.

the parameters are

Sap.useWebDynproStyleSheet = true

Sap.theme.default=<path to correct theme directory>

hope it helps.