cancel
Showing results for 
Search instead for 
Did you mean: 

Create condition with PR Purchasing group

oluwatosin_oladipo
Participant
0 Kudos

Hello all,

Please i need urgent response to this issue. BUS2105 does not have Purchasing Group as part of its attribute, but i need to create a start condition with this attribute (Purchasing group) in my PR approval workflow.

I created this attribute  reading from EBAN - EKGRP, but the workflow still does not get triggered when i use the attribute as a start condition.

Please, kindly elaborate on how to achieve this requirement. thanks in advance

Accepted Solutions (1)

Accepted Solutions (1)

former_member185167
Active Contributor
0 Kudos

Hello,

Does the attribute show the correct value when you test it in SWO1?

How did you word your start condition?

regards

Rick Bakker / hanabi technology

oluwatosin_oladipo
Participant
0 Kudos

I just tried again, the business object does not generate when you try to start it, and in the workflow, my condition is If purchasing org = 100

How do I create this attribute to work with.

anjan_paul
Active Contributor
0 Kudos

Hi,

  Adding the attribute only does not mean it will populate with value in business object.

The best way is use the Check function Module in SWE2. You select the purchasing group based on Purchease requisition no . Then check if  is 100 then trigger the event.

How to use check function module you can get this link http://www.saptechnical.com/Tutorials/Workflow/checkfunctionmodule/demo.htm

Answers (2)

Answers (2)

Former Member
0 Kudos

Did you create the attribute in the object directly or in a sub-object? If you created it in a sub-object, did you maintain delegation?

Former Member
0 Kudos

Can you please elaborate on how you added the attribute?

oluwatosin_oladipo
Participant
0 Kudos

I used transaction SWO1, clicked on attribute, create and i used the ABAP field proposal, using table EBAN, and used object type TO24

former_member185167
Active Contributor
0 Kudos

Does the attribute show the correct value when you test it in SWO1?