cancel
Showing results for 
Search instead for 
Did you mean: 

CR-Runtime 13.0.29 - CrystalReportsViewer - Text is not shown completely

former_member908278
Discoverer
0 Kudos

Hi there,

we use CR-Runtime in our windows application to show, print and export reportfiles (*.rpt).

Some of our Reports have a strange behaviour in Preview from using the Crystal Reports Viewer, the content is not completely shown. We use Crystal Reports 2016 to create/edit reports, and in there, the preview is correct. Print works fine in both.

Here an example image of the problem:

Any ideas what causes this? The thing is, that we can not reproduce this on any computer, but a lot of our customer report us this problem.

Thanks and Regards
Antonio

Accepted Solutions (1)

Accepted Solutions (1)

DonWilliams
Active Contributor
0 Kudos

One thing that may fix it is CR requires the default printer to be used on the WEB server to be the same as when the report was designed.

Open the report in CR Designer and select Page Setup and check on the Dissociate option.

That may help..

The master KBA is here:

https://userapps.support.sap.com/sap/support/knowledge/en/2165260

May not help though because I believe this is a missing dependency on the WEB server.

Use Fiddler to trace what's being loaded on the WEB server and look for Not Found errors.

Answers (5)

Answers (5)

killersittich22
Discoverer
0 Kudos

Hello,

I tried as Mr. Williams suggested and checked on the Dissociate option in page setup.
No positive effect.

In the master KBA I dont find an entry "to adjust spacing".

We dont use any webserver with CR

The problem is shown on every page, not only the first one.

But: I'm able to show some text-fields in preview by changing empty lines to one space(!) But this wouldnt help, if multi-lines will be constructed by formulas.
Will this "little workaround" give a hint for a solution?


I'm very unhappy, because the users have to go using pdf export to see, if the output will be ok. Or they'll print x-times, until everything is right and waste a lot of paper.

Thanks for your support,
Holger

killersittich22
Discoverer
0 Kudos

in addtion:
the first line of the textfield will be shown, but if it contains a formula, the content of the formula will not be shown too.

DonWilliams
Active Contributor
0 Kudos

Try SP 33 - https://wiki.scn.sap.com/wiki/display/BOBJ/Crystal+Reports%2C+Developer+for+Visual+Studio+Downloads

And search for Master KBA for all registry keys, look for the one to adjust spacing

killersittich22
Discoverer
0 Kudos

Hello Mr. Williams,

thanks for the answer. But I'm an "admin beneath a fulltime job" and customer, so I have some (silly?) questions:

What is meant by "search for Master KBA for all registry keys, look for the one to adjust spacing"?

And if I've found it: what shall I do (only "look for" wouldn't solve the problem...) 😉

Holger

killersittich22
Discoverer
0 Kudos

Hello,

the same problem exists in Windows 10 1909 and remains in Windows 10 22H2.

Is there any solution known after two years since the first post from A. Cambule?

Holger

former_member908278
Discoverer
0 Kudos

It is one big textfield.

My colleague from support said it is only on Windows 10 build 2004,
on previous Windows Versions (i use 1909) it works fine.

Same report, same database, same record.

screen:

0 Kudos

That is very odd behaviour.

It suggests some dependency you have is missing from the Users PC's.

Is that all one object or part of the first part, the 3 lines before the missing part?

Is that data on the next page?

If it is it suggests the Printer page setup needs the Dissociate option checked on.