Showing results for 
Search instead for 
Did you mean: 

CR: Can't get remote files in Reports

Former Member
0 Kudos

Hi there,

When i design the reports template, the report needs to get some specific files locate at one of my files server.. the access way is network SMB sharing like

When I tested the report template in my development PC, I found the report could be generated without any issue, and the remote file could be got as expected. However, When I deployed the report to Crystal Reports Server 2008, the specific files can't be got and the report failed to generate..

Then, I did 2 step to address this issue:

1. Create one folder and assign the permission as Everyone modify, then run the reports at CR Server 2008.. the files can be got and reports display well. ---- I suppose there should be an account issue

2. Enable folder audit option in my file sharing server, then run the report to access this folder... I found the access account used by CR Server 2008 is anonymity and didn't send any credence to my share server

Since it's not a standard/security process to allow everyone to access these specific files, is there anyone can help me for this issue?

the best way in my mind is to setup an account in the reports, which could be used to access remote URL path, but i don't know how to do that...

Thanks very much

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

By default, the services that run CRS are set up to run under the "Local Services" account on the server where they're installed. This account has access to anything on the server, but no access to secure network resources.

Best practice is to create a network "service" account for running these services and set it so that the password never expires.

You then go to the Central Configuration Manager for CRS and

1. Stop the Server Intelligence Agent (SIA).

2. Open up Properties for the SIA.

3. On the first tab, under "Log On As", uncheck "System Account" and enter the user ID and password for the network. If you're using Active Directory, the user ID has to be prefixed with the AD domain.

4. Save and restart the SIA.

Set up security on the folder where the images are located so that the network account used for the SIA has access.


Answers (1)

Answers (1)

Former Member
0 Kudos

Would it be easier to just copy the files onto a folder on the Report server. Then update report to look at that location.