cancel
Showing results for 
Search instead for 
Did you mean: 

Could not retrieve iView - Access denied (Error 2147024891)

Surferpeck
Employee
Employee
0 Kudos

Hi there,

This one is killing me! All iViews were working fine. To my knowledge, no changes have been made on the IIS. I get the following error:

*****

Could not retrieve iView

Error: - -2147024891

More details...

Access is denied.

*****

The iViews in question are in the folder SAPPortal\IE\iView_runtime\content_pages. Most are just information pages written as .htm or .asp pages.

All portal_admin iViews are working fine.

Any thoughts??

Cheers,

Chris

Accepted Solutions (0)

Answers (4)

Answers (4)

Former Member
0 Kudos

hi all!

we got a similar error like this one. There have been made no changes on the portal server.

The error is following:

Could not retrieve iViewError:-2147012744

Can you please help us.

Thank you! michal

Former Member
0 Kudos

We had this problem last week.

We are running EP5 SP5. The XMLPARSER 4.0 PS1 was upgraded to SP2 after the McAffee upgrade ( We did not know that Mcafee upgrade would upgrade also XMLparser 4.0). Basically Mcafee upgraded also the XML parser sp1 to sp2.

If you search over the internet, you can not find anywhere the XMPL parser 4.0 SP1 which is supported by EP5.

We got a patch from Microsoft that allowed a "downgrade".

Now our portal works but still send the occasional "Could not retrieve iView

Error: - -2147012744".

Surferpeck
Employee
Employee
0 Kudos

Hi all,

I found the problem with this one! Someone installed MSXML 4.0 SP2 on the Portal Server. In the Installation notes of EP50 SP5, there is a note that MSXML 4.0 SP1 ONLY is supported. Therefore, The Access Denied message is displayed.

Thanks for you responses,

Chris

Former Member
0 Kudos

We have the identical problem, with no .Net iViews being displayed. ALthough we have been running with MSXML 4 SP2 for a while so something else interacts with it maybe?

Did you ininstall MSXML4 and re-install a lower patch level?

Where did you get the lower patch level from, only MSXML4 SP3 is available on microsoft.com?

Former Member
0 Kudos

Hi,

Basically more authentication credential should be provided for this Iview access.Try checking it in the PCD with your Component inspector whether it is been installed properly.

Thank you

arun

Former Member
0 Kudos

Well, the error is coming from the portal, so have you checked if the user starting the portal (or the service user) has access to the files ?