cancel
Showing results for 
Search instead for 
Did you mean: 

Could not load data in cube using a generic extractor from a FM

former_member355937
Participant
0 Kudos

Hello Experts,

I created a generic extractor referencing from a function module by customizing the FM RSAX_BIW_GET_DATA_SIMPLE.

When I tested it using the extractor checker (RSA3), it is working fine.

But when I use it as a datasource to load the data result into a cube, for some reasons it is not working.

The extraction took very long time that had exceeded the timeout setting of the infopackage.

It didn't even posted to the PSA table.

The data contains only 9,561 records.

But when I tried limiting the data result of the FM to 10 rows, it worked.

Really need your advice on this.

Thanks in advance!

Jeffrey

View Entire Topic
Former Member
0 Kudos

Jeffery,

The code you have writeen is stuck because the there is no limit on data package size in case of Funtcion module and the probably the code is stuck at some select statement and works well if you test it with small number of records per calland therefore the select statement may not be creating issues.

But when extracting the data into BW you will getting all the records in one call therfore the amount of records getting extracting will also go huge and without proper use of indexes on the table it may be taking a very long time to read the values.

Just try to debug it in RSA3 and give the no of extraction per calls and records per call to 20000 and then run it in Debug mode and then see on which line its stuck...it will give you a better idea.

Thanks

Ajeet

former_member355937
Participant
0 Kudos

Hi Ajeet,

Thanks for your response. I already handled the extraction per calls in the FM. For example if the total record of the data I am extracting is 9000, it will be divided to the number of calls I have specified in my infopackage.

In the extractor checker, it works fine even if have extracted the whole data.

I just couldn't figure out why it is not working when I am loading it to the cube.

Thanks and Best regards,

Jeffrey