cancel
Showing results for 
Search instead for 
Did you mean: 

Conversion of Characteristic Values to SIDs. Load Very slow

Former Member
0 Kudos
216

Hi Experts,

We have a slow load issue when loading from a Write-Optimized DSO into an InfoCube. 8 millon recs in 10 hours.

We check the start, end, and rules routines and every is ok but for all the package the load was very slow in the Conversion of Characteristic Values to SIDs.

Can any help me with this?

Thanks a lot,

Alejandro

Accepted Solutions (0)

Answers (7)

Answers (7)

Former Member
0 Kudos

Check reads on table NRIV during loading and activate number range buffering, see [this article|http://www.sdn.sap.com/irj/scn/index?rid=/library/uuid/c0a6e3ff-f000-2d10-b59d-8ef35e248f83] for reference.

Also take a look at the latest available EarlyWatch, it should list top unbuffered dimensions and infoobjects and give insight

Former Member
0 Kudos

Hi Alezandro,

Delete the index of the cube before loading data from Write Optimized DSO to the CUBE. After successful loading of data to the cube recreate the index of the cube.

Navesh

former_member188080
Active Contributor
0 Kudos

Hi,

Just check following thread as well for various parameter settings

Thanks and regards

Former Member
0 Kudos

hi,

Are you performing complete deletion of cube and then loading the new data, if yes then it will take time as it tries to create DIM ids and then SIDs for the data, Instead use delete overlapping request. The SID activation at the write Optimized will not help as it would increase the loading time of the write optimized DSO.

regards,

Arvind.

Former Member
0 Kudos

Hi,

It is because the SIDs Generation upon Activation flag is unchecked at DSO level .

One recommendation will be to switch on the property of the DSO SIDs Generation upon Activation flag .

Are there any secondary indexes also in DSO ?

You can try deleting them also during loading the data from DSO to cube .

Also load your master data first and activate it before loading it to cube.

Thanks,

Former Member
0 Kudos

Hi,

It is because the SIDs Generation upon Activation flag is unchecked at DSO level .

One recommendation will be to switch on the property of the DSO SIDs Generation upon Activation flag .

Are there any secondary indexes also in DSO ?

You can try deleting them also during loading the data from DSO to cube .

Also load your master data first and activate it before loading it to cube.

Thanks,

Former Member
0 Kudos

Try to do loading by deleting index and then create index.I think it may works.

Thanks,

Mahesh