cancel
Showing results for 
Search instead for 
Did you mean: 

Connection Timout in BSP application

Former Member
0 Kudos

Hi,

How to increase the connection timout for BSP application. I get the following error,

500 Connection timed out

Connection timed out (-5)

-


Error: -5

Version: 6020

Component: ICM

Module: icxxthr_mt.c

Line: 2476

Server: systdemo

Detail: Connection to partner timed out

I am displaying order list in an BSP page.If i select less number of orders it works properly but when i increase the number or orders i get this error. How to handle this?

Thank you

arun

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi,

I am using the TableView and the assigned Internal table to get the Order list. Since i make multiple select from different table it takes a long time.

I checked the Profile parameter icm/conn_timeout and it has the following value,

Minimum 0

Maximum 9,999,999

Dflt value 5000

ProfileVal 5000

Current value 5000

What is the value that controls the BSP application to wait somemore time till it gets the Order list formed?

Thank you

arun

former_member181879
Active Contributor
0 Kudos

These running times are configured in profile for ICM. One of my weblogs discuss this.

Let us first do a test. Start transaction SMICM. Menu goto->services. Then in first menu, select "create new service". Define the parameters HTTP, port=7878, and timeout=900. This is a new port activated until machine is restarted. Now within the browser, change the port number in the URL to be 7878, and test again.

Then we must find that old weblog so that you can read up on this.

Former Member
0 Kudos

Brian, isn't this the same as changing the value for parameter icm/keep_alive_timeout? Why is creating a new service perferred above modifying an existing parameter from an existing service? Tiest

former_member181879
Active Contributor
0 Kudos

Tiest,

There are two interesting timer values. The one controls the time that one HTTP request may be processed. The other the maximum time allowed before the next request must be there.

I would recommend reading this weblog: <a href="/people/mark.finnern/blog/2003/09/24/bsp-in-depth-confusion-between-stateless-stateful-and-authentication">BSP In-Depth: Confusion between Stateless, Stateful and Authentication</a>. It contains a lot of information on this topic. (Including detail instructions, screenshots, etc.)

brian

Answers (2)

Answers (2)

Former Member
0 Kudos

How are you displaying the records? Are you using a TableView or building the table manually?

The timeout is a setting in RZ10 I believe you can get to it from SMICM as well.

Former Member
0 Kudos

I believe by modifiying the value of parameter icm/conn_timeout should your should be able to influence the time a connection stays open. Use transaction RZ11 to look-up this parameter and change it's default value. Tiest