cancel
Showing results for 
Search instead for 
Did you mean: 

Connecting multiple SAP Systems

Former Member
0 Kudos
95

Hey all

I know that we can connect multiple systems with enterprise portal. But my situation is like this that I have SAP ECC 6.0 as well as SAP R3 4.6 C. ECC system is just for testing purpose so i need to connect with it ESS and MSS Business Packages for my developers to test various functions in the newer SAP Version. Along with that I also need to connect EP with SAP R/3 system which is live and being used by our end users. They also need to perform activities in the same 2 packages i.e. ESS and MSS.

So my question is can i connect few of my users with ECC and others with R/3 4.6C. on the same Enterprise Portal on the same 2 business packages (ESS/MSS)

Regards

-Bilal Nazir

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi,

both parameters in the URL should have the same suffix e.g. "R3Q" OR "HRQ", from your last post I got the impression you mixed them:

(sap-wd-arfc-useSys=SAP_R3_HumanResources:R3Q&sap-wd-arfc-

useSys=SAP_R3_HumanResources_MetaData:HRQ)

Does this help?

Best regards, Johannes

Former Member
0 Kudos

Hello

sure, that is no problem. Do like this:

1: Make two system definitions in the system administrator with two different system alias

2: Deploy the BP for ESS (for the ECC version) and connect this content with the right system

3: Deploy the BP for ESS (for the R/3 version) and connect this content with the right system as well

Former Member
0 Kudos

Hey Kristoffer

Wanted to clear one more thing. You see, for getting the data from the backend system we use JCO connections. Right ?

And I believe we have same names for those connections. So should i make a copy of each of them and just change the logon details in them or what ?

Regards

-Bilal Nazir

Former Member
0 Kudos

If you are going to access same SAP system , you can use the same JCO settings .

For accessing another SAP system , create new Jco connections

Points are welcome if it is helpful

Koti Reddy

Former Member
0 Kudos

Hey Koti

Yes i stated in my first post that i am using 2 different systems. And I want a few users to connect with one of them and others with the other. And they all will be using the same business package, just that the data they need to view would be coming from different systems.

So you are saying it is possible and all i need to do is create another set of JCo to connect to the other system ? And can i have a similar name for 2 different JCo Connections?

Regards

-Bilal Nazir

Former Member
0 Kudos

Hi,

there is a possibility to use an additional URL parameter: sap-wd-arfc-useSys=<Jco_destination>:<Suffix>. Using the suffix you can maintain additional connection info for your second system. The parameter can then be entered in the relevant iViews of the Business Package.

For more details see: http://help.sap.com/saphelp_nw70/helpdata/EN/af/84a34098022a54e10000000a1550b0/frameset.htm

Hope that helps,

Johannes

Former Member
0 Kudos

Hello,

Currently we are trying to use "sap-wd-arfc-useSys"

parameter for standard ESS/MSS Iview to connect to a different R/3

system for some ESS/MSS webdynpro application. But it throws an error

as mention below.

Caused by: com.sap.tc.webdynpro.services.exceptions.WDRuntimeException:

Accessing System R3Q is not possible because RFC Metadata was retrieved

using System HRQ. Please assure you have configured the RFC Connections

properly. A Server restart may be necessary!

Configuration Step Performed:

I have a finance R/3 system and also an HR R/3 System.

I need to be able to use the FI system for the timesheet ESS screens

and the HR system for the others. I have used the iView Application

parameter as documented;

(sap-wd-arfc-useSys=SAP_R3_HumanResources:R3Q&sap-wd-arfc-

useSys=SAP_R3_HumanResources_MetaData:HRQ)

The JCo destinations have been configured and do work ....

Is there any way of getting this to behave properly and make sure that

the right Jco connection is used. It is very frustrating because the

configuration is correct, I just need to be able to force the

applications to use the the Jco destination that has been defined for

the iView.