Showing results for 
Search instead for 
Did you mean: 

configuring as integration server

Former Member
0 Kudos

Hi All,

I am trying to test the xi installation. I am trying to test a simple scenario with file adapter. File-xi-file. File adapter is picking the file but it is not reaching the integration server.

I am on XI 3.0 sp14.

SXMB_ADM --> Integration Engine --> Configuration --> Integration Engine configuration

These are the values I have

Role of Business System = Integration Server

Corresponding integration server =

Value of http port in 8000 (from SMICM-> goto(Menu)„³ services (Menuitem)

My question is what is the value for ¡§Corresponding integration server¡¨ on the xi box.

1. does it need to be blank since it is the xi server(integration server) itselt

2. http://ip:8000/sap/xi/engine?type=entry

3. if I go to edit(Menu)-->change global configuration data(Menu Item) --> system landscape (button) , it is populating


Which one of the above is correct, If I change it do I need to restart the server.

Thank you,


Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos


Have you tested the 4 RFC Destinations that u woud hav created while installing.R they workin fine .

What is the system error that u r gettin in SXMB_MONI

Former Member
0 Kudos

I have gone through the readyness check list, and tested all the rfc connections, those are working good.

I don't see any mesages in SXMB_MONI.I think messages are not coming till integration engine.

I have checked the file permitions on the unix box, theyy look good.

Answers (4)

Answers (4)

Former Member
0 Kudos


Do you know if the SAP NetWeaver Sneakpreview includes XI? if not is there a downloadbale XI to work with SneakPreview version?



0 Kudos

Hi Ganges,

On the Integration server, the value of 'Corresponding Integration Server' needs to be blank.

On the application systems, it should be filled in with the pipeline URL http://<server>:<httpport>/sap/xi/engine?type=entry

You should check the Adapter monitoring http://<server>:<j2eeport>/mdt/amtServlet. This will highlight any errors that are occuring in the Adapter while processing the file.

If you are using file conversion, then it could be that it could not find any records to process, and thus just gives up. In that case, just check your file, and your conversion config in the adapter as well.



Former Member
0 Kudos

Hi Manish and aravind

Thank you for the quick replays.

These are the things i tried.


-left it as blank (since documentation says that)

- Installation document tells , we need to leave it as blank. I am looking into "SapExchange infrastructure 3.0 installation", in postinstallation section, under performing masic configuration settings in page number 22.

- but did not work


- I have added the entry like this http://ip:8000/sap/xi/engine?type=entry

- I have checked other XI server from previous client it also got in the same format. I don't know why they have configured like that even though it is not required as per documentation. I don't know there is any note on this

- this option is not working

Option 3

- Changed in the SLD under business system .

- and asked it to populate it from SLD by clicking the Buttom. It popolated but still not working.

I am not doing any file content conversion, or any mapping, just reading a file from one unix folder and trying to write to different folder.

This is the error i am getting in the adapter monitoring

Sender Adapter v2300 for Party '', Service 'SAP_FTP_SYS':

Configured at 2006-02-23 15:13:47 UTC


- 2006-02-23 16:30:00 UTC: Retry interval started. Length: 60.000 s

- 2006-02-23 16:30:00 UTC: Error: File '/export/home/ptacket/xi/source/in.txt' - deleting after processing failed

- 2006-02-23 16:30:00 UTC: Processing started

- 2006-02-23 16:29:00 UTC: Error: File '/export/home/ptacket/xi/source/in.txt' - deleting after processing failed

- 2006-02-23 16:29:00 UTC: Processing started

Former Member
0 Kudos

Hi Ganges,

If you still face problem test the RFC Destinations created while installing .



Former Member
0 Kudos

Hi Ganges,


this is the pipeline url which u hav to give in the global configuration data.Check for the correctness of the pipeline url in ths SLD int he business system which is used as integration server.

A restart will do wonders