cancel
Showing results for 
Search instead for 
Did you mean: 

Configuration Afaria7.0 with Android mobile

sbmrafikul2
Participant
0 Kudos

Hello,

I am new to Afaria.

Currently I am installing and configuring the Afaria 7.0 in my landscape(OS --Windows, DB - SQL). I have successfully installed all the component Afaria Server, API & Administrator etc.  Now I want to connect it to my android mobile to see the features of Afaria.

Could anyone guide me how to do that any configuration in the mobile device etc. 

Thank You.

View Entire Topic
Former Member
0 Kudos

Hi there,

this documentation might help :

Afaria 7 Administration Reference (English) on http://frontline.sybase.com/support/

Page 17...

"Android Management Life Cycle

Manage devices using an Afaria application, as published to a commercial market.

The market is managed by a third party, with Sybase as the client’s developing entity.

This life cycle is generalized:


1.

The user installs an Afaria application from a commercial Android market, such as Google Play.

2.

Enroll in management to connect the device to the Afaria environment.

3...."

sbmrafikul2
Participant
0 Kudos

We have successfully installed the Afaria client in the mobile device. Now when we put the enrollment code it says that the code is "incorrect code referred"

Any hint

Former Member
0 Kudos

Hi Jens,

My problem is  when trying to connect a device Android 2.2, throws me the following error in the log of Afaria Server.
"XRS1371: User dayana on 5dcf6d32e5b1559b (xxxx) is not assigned to channel android. The connection was refused. EXPLANATION: Only Assigned users may run this channel. ACTIONS: This is an informational message only. No action is required."

Then I create a channel Afaria Administrator Channel for Android, however when I try to assign the channel to a group, I see nothing in the channel list. This only happens to me with Android, because with WM if I associate the channel to a group

I appreciate any information about

Former Member
0 Kudos

I forgot to say that if the channel is published

sbmrafikul2
Participant
0 Kudos

Is there any configuration we have to made in the afaria client, which we installed in our android mobile device.

By default we see that in the configuration part it tales xnet://0.0.0.0:3007 as server . Should we have to change that to our server IP.

Once we change it to our public IP there the enrollment code page is not coming and it says connecting the server successful but the client is not approved.

Any hint

Former Member
0 Kudos

Sorry Leidy,

I am not fit in using channel. But I have learned, that I do not need to use
channels to simply controlle a device. My enrollment code configuration looks
like:

Former Member
0 Kudos

  Hi Jituda, as far I know you don’t have to modify the Afaria client configuration.
All relevant information are included in the tiny url. You can check the tiny
url on the following screen.

Former Member
0 Kudos

sorry Jituda, not without going through the Server configuration.

sbmrafikul2
Participant
0 Kudos

Thanks Jens.

We have now face another issue. The service for Afaria Server goes down automatically. If I start it it goes down after few second.

Former Member
0 Kudos

Hi, I had the same issue. When I remember, I did the following steps:

1. Disable!! all Afaria Sercices

2. kill all Afaria task/processes with the taskmanager.

3. Reboot the ms server.

4. After reboot, start Afaria service first.

Good luck

Former Member
0 Kudos

Tthx Jens,

According to your advice, do not use with channel settings and thanks to this device successfully connects and "Last Connection: Succeeded at ...." however when I try to enter enrollment code on the device shows me the following message "Incorrect Enrollement Code Entered" , could you please help me.

Former Member
0 Kudos

Hi Leidy,

hard to say without looking at your system.

I guess, you checked the enrollment code and it was correct?

Some tips which helped me:

- Use a 'clean' device and delete all device data fromthe Afaria Server.

- Check the tiny URL of the enrollment code. (howto, look next article)

- and, sorry,  a stupid tip : check the configuration agains the Install and Administration Documentation.

Sorry, maybe someone else has an other idea.

Jens

0 Kudos

Hi Jituda,

Restart should help here. Also, make sure there is no port conflict.

Regarding "Incorrect Enrollement Code Entered". Check that tiny URL code URL (long one, actual URL) should be reachable from your device.

Please try to clear the cache of Afaria client application from application management. You can also get the logs from device by connecting it to eclipse.

Regards,

Abhishek Joshi

sbmrafikul2
Participant
0 Kudos

Thanks guys. Yes restart the system help me to resolve the issue. Now the service come up and in running status.

But after putting the enrollment code in my mobile device got the message that "enrollment failed"

I am using

--Tiny URL to configure the enrollment code

--I used https in IIS with port 8850

--I used self signed SSL certificate there.

My doubts are in Afaria Administrator the Server--> device communication ,what configuration I have to put. I see xnet (default already selected) http, https,xnets . Is here also i have to select https as port 8850 or other port? In the same tab certificate area which certificate i have to produce (the  self signed certificate only which i used in IIS or other certificate from third party like versign etc). Also in the adress for device communication which IP i have to put .

Any hint

Regards

jituda

sbmrafikul2
Participant
0 Kudos

Also what I observe that I am not able to access the tiny URL for the enrollment code

When I try to access this link in the system got a blank white sheet only.

Former Member
0 Kudos

Hi,

are you using a relayserver? So this configuration is for this case:

Protocols and ports: I use the Standard ports. No https on internal traffic.

Adresse for Device communication: This is the access point from the internet. Put in the external address with the port for https access.

Certifcate Setting: I don't use a certificate for the intern traffic between relay server and afaria. for this case is no configuration necessary.

Regards

Jens

0 Kudos

Hi Jituda,

Thats ok.

Please check that you are able to open/access the server which you get from Long URL.

My doubts are in Afaria Administrator the Server--> device communication ,what configuration I have to put. I see xnet (default already selected) http, https,xnets . Is here also i have to select https as port 8850 or other port?

Answer --> It's up to you. We are using http port 3009 here for device communication. It should not be same as your IIS ports. Here Afaria server will listen.

In the same tab certificate area which certificate i have to produce (the  self signed certificate only which i used in IIS or other certificate from third party like versign etc). Also in the adress for device communication which IP i have to put .

Answer --> You can use self-signed cert. Make sure that during installation of iPhoneServer (Enrollment Server), you select the same cert and your https port.

Regards,

Abhishek Joshi

former_member745479
Participant
0 Kudos

Hi Jens,

I see that in Address Communication, you are using port "443" HTTP(s) connection. Presumably, this is applicable for Android devices.

How are you managing the http(s) communication between Android device and Relay Server ? Are you installing any certificate on the device before enrolling or during enrollment it is taken care of ?

Thanks,

Viju

sbmrafikul2
Participant
0 Kudos

Thank you.

yes now I am able to enroll device in the afaria administrator.

I tried to create a policy so that I can disable the device bluetooth option. For that I have first Created a enrollment Policy for Android, Create static group, and then created a configuration policy to disable the scan device & Bluetooth devices and later link those three.

But when I add the device to this policy it send a notification message but its not disable the bluetooth in the device. At the same time we see a message in the server log

ONS1024: Expected to notify the Client, "xxxxxxxxxxxxxxfda", with Client GUID, "{74cccccA-1D57-3E44-9828-848EA7DBBD09}" at Address "xxx.yy.rr.ww"(IP address of the server), but instead found the Client, "hostname of the server", with Client GUID, "{D307F801-04A1-4B27-8840-C35C5406E198}" at that address.

Also,

We are configuring the afaria so that we can handle the android mobile device in case of disable the camera, youtube and for update of any software. we do not want the messeging or sending mail from server to device facility. In that case should we have to configure the "Define SMTP" in server configuration area.

Also another point why we are using the "Define C2MD Server" part . Is it mandatory field to configure the Afaria with a Android device or not?

Any hint

Regards

Jituda

0 Kudos

Hi Jituda,

To configure afaria to handle Android devices notification (push), you would need to configure GCM (google cloud messaging). I think C2DM is not there any more. In this case you would need to apply hotfx 17 to get GCM feature.

SMTP is for email option. If you want to send policies and enrollment through email then you can use this. Also it can be used to notify user with any information.

C2DM is already deprecated as mid of 2012. It has stopped accepting new users. So you would need to configure GCM here.

Regards,

Abhishek Joshi

Former Member
0 Kudos

Hi Viju

First in line we need the 443 port for iOs devices communication.

All Information are embedded into the tiny URL of the enrollement code. i am not installing any certifcate on the device.

For further information please have a look on the documentation on frontline.sybase.com. Administrator Guide, Page 13...:

http://frontline.sybase.com/support/(F(zHtxUwtdMA4CagBlAG4AcwAuAHQAcgBhAHUAdABtAGEAbgBuAEAAYQBrAHEAd...

and

Installing guide, Page 59...

http://frontline.sybase.com/support/(F(zHtxUwtdMA4CagBlAG4AcwAuAHQAcgBhAHUAdABtAGEAbgBuAEAAYQBrAHEAd...

regards jens