Showing results for 
Search instead for 
Did you mean: 

Compatibility issues of SAP fiori for ios framework with swift 3.2/xcode(9.3) & higher version

0 Kudos

Dear All,

I have downloaded the SAP Fiori for ios framework and created a xcode project using SAP Cloud Platform SDK for iOS Assistant app.

However during build am getting an error"Module compiled with Swift 3.1 cannot be imported in Swift 4.0:".

I tried changing/downgrading my swift version by changing the same in build settings but in vain.

Xcode 9.3 supports swift version 3.2 and higher but SAP provided framework has support for swift 3.1.

I got some help in google stating that xcode 8.3 has support for swift 3.1.

Any pointers on how to proceed with Xcode 9.3/swift 3.2 & higher including SAP Fiori for ios frameworks?

Best Regards,


Accepted Solutions (1)

Accepted Solutions (1)

Active Contributor
0 Kudos

From your error message I assume that you are using the SDK version compiled for Xcode 8.3 with Xcode 9 beta 3. Please make sure that you download the SDK version compile for Xcode 9 beta 3.


Active Contributor
0 Kudos

Dear Forlian,

excuse me, I just upgraded to Xcode 9.0 and also just downloaded SDK version "Version 1.2.500-ms-08-16b" and since I can just start "re-generate proxy classes" for an existing project I simply thought, that this would be it. But Xcode 9.0 still complains, that "XXXXXXXXX.swift:8:8: Module compiled with Swift 3.1 cannot be imported in Swift 3.2: /Users/XXXXXX/Demosap3/SAPOData.framework/Modules/SAPOData.swiftmodule/x86_64.swiftmodule"

The "regenerate" seems to work without problems, opening Xcode 9.0, but the sin turn issues immediately the error message above.

So what should I do?

Kind regards,


Answers (1)

Answers (1)

0 Kudos

You can also find a bit more detail in this blog: