cancel
Showing results for 
Search instead for 
Did you mean: 

Comp mime type 'text/plain;charset=utf-8' instead ''

ashish_pancholi
Explorer
0 Kudos

hi Team,

I am new to SAP and learning about SAP http interface APIs and RSCMSTH2 report execution using Tcode SE38.. 
I am facing an issue while sending a response for /info and /get API for a 0 bytes component file for a document.

ashish_pancholi_0-1717073537747.png

 

 

as you see in above screenshot,
1. for a /info API for DOC_0 (which is 0  bytes document but actual comp data length is 2) is giving an error message for mime type, it is expecting that mime type should be empty,
2. for a /get API for DOC_0 which is again for 0 bytes component, gives an error message for mime type where it is expecting " " (whitespace in mime type)

 From codebase standpoint I tried sending no content type for /info request then execution of report RSCMSTH2 is not working,
And we can not send empty content type (mime type) with http headers from codebase which is restricting us to not send whitespace as it is expected for /get API.

I need your help on this mime type which SAP is expecting and how can we send it to SAP from our content server. 
Also do we need to send response as 200 OK for 0 byte component document or something else.

Please help me to fix this issue, or let me know if I need to check something else to get resolve this given issue.

Note: we are implementing it for 3rd party content server, and implementing all SAP HTTP server interface API by ourselves.

 

Thanks

Sandra_Rossi
Active Contributor
0 Kudos

The screenshot is too small, I don't see.

Here is mine:

Sandra_Rossi_0-1717067016767.png

ashish_pancholi
Explorer
0 Kudos
Sandra_Rossi
Active Contributor
0 Kudos
It's a standard program, you should not fix it. It works well in my system. Just contact the SAP Support.
View Entire Topic
ashish_pancholi
Explorer
0 Kudos

hi @Sandra_Rossi ,

I have updated ticket correct screenshot,

meanwhile I was able to fix couple of more issues, only 1 issue is remaining now.. which is related with /get DOC_0 to fetch 0 byte document, could you please help how SAP is trying to verify the Content-Type header as " "(blank) because as per 3rd party content server interface I am not allowed to send blank content type for any request..

resulting I am block at this.. Please suggest any idea on how can I fix it from my side..

Sandra_Rossi
Active Contributor
0 Kudos
Thanks, I can clearly see the screenshot now. No idea why SCMS_HTTP_GET returns a blank MIME type, in my system it's blank also but no problem to be blank. Now, I think that you should ask a question about your custom code, not about a SAP internal program, you should ask SAP Support, not the community.
ashish_pancholi
Explorer
0 Kudos