Showing results for 
Search instead for 
Did you mean: 

Combo Box Empty on Preview

Former Member
0 Kudos


I have a combo box that has the following labels: Avg Cost, Total Days, Total Cost.

The labels are in columns in a spreadsheet going across. Not in rows...

So my label range is A1:A3...

When I look at the combo box on the design all the labels are populated in the list.

But when I "preview" the combo box it shows up totally empty...

Can someone please help?

Former Member
0 Kudos

Hi there,

My product is Xcelsius Engage

Build 12,3,0,670

What service pack or fixes would I need?

Former Member
0 Kudos

Hi there,

I updated to the latest Crystal Xcelsius Version. It's now

But I think I found a possible bug or the reason why the selector list isn't showing up.

I did another list box that has Age Groups. Less Than 30, Between 30 and 40, etc...

The list is in rows and I did a filtered rows option.

It worked fine. I had it linked to both a spreadsheet table and a graph.

It even worked on Preview....

BUT - I added the Crystal Reports Data Consumer as my connection.

and as soon as I did that. The List Box went blank on Preview....

When I removed the Crystal Reports Data Consumer Connection the listbox populated on preview...

So my question is, this seems like a bug.. Shouldn't the list boxes work even when there is a Crystal Reports Data Consumer Connection set-up?...

And my next question, if this is a bug... When will it be fixed????

Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

You are correct the exact location of the labels are in columns, I wrote it wrong previously.

It's Sheet1!$G$4:$I$4. And I tried it with the combo box component and the listbox component.

I get the exact same behavior. The list is populated in design mode. But when I preview they disappear.

I tried it with rows to see if they worked with the labels in rows and they both work fine with the labels in rows.

But mine have to be in columns. So that won't work for me.

Is there a fix for this?

Former Member
0 Kudos

Hello DashBoardNewbie,

You have said that the selection for Combo Box is in columns going across, then the range should be from A1:C3. But what you have said is the selection is from A1:A3, which is in rows. So please check whether the range you have selected is the correct range or not.

It doesn't matter whether you have selected the labels for the Combo Box in Columns or in rows. It will always display those labels which you have selected in order. So do check whether you have selected the rest of the properties of Combo Box lile list transparency,or whether you have selected the range for Labels or Title or the Colors have been set properly.

If still you are not able to see then probably it could be a problem with the component. Try the same labels with the filter component and check other components whether they are working properly. If not try reinstalling Xcelsius again since these problems occur sometimes during installation.

Thanks & Regards,


Former Member
0 Kudos


Your label range you selected wrong .

You mentioned as The label are in columns.

So that you have to select "Sheet1!$A$4:$C$4" ,

Try with this ..