cancel
Showing results for 
Search instead for 
Did you mean: 

Client PC deployment problems

Former Member
0 Kudos

Hi,

We are developing a .NET client application that integrates with Crystal Reports Server 2008.

On my development PC (with Visual Studio 2008 and Crystal Reports 2008) the application can access the report server with no problems.

However, on client PCs with the application deployed, we are getting the following error:-

Retrieving the COM class factory for component with CLSID {E063B04A-Cb8B-460E-99D0-F7D8FA2FAAA2} failed due to the following error: 80040154

We have deployed the Crystal runtime using CRRuntime_12_1_mlb.msi and also run the client tools installer from the server install.

What else needs to be installed on these PCs?

Thanks

Accepted Solutions (1)

Accepted Solutions (1)

ted_ueda
Employee
Employee
0 Kudos

That CLSID is for the XI 3 SP 1 Enterprise SessionMgr.

Current Crystal Reports Server 2008 RTM does not come with the .NET Runtimes, since it didn't support it.

Business Objects Enterprise XI 3 RTM didn't come with .NET Runtimes either - it was introduced with XI 3.1 (3 + Service Pack 1). It's a separate msi file from Crystal Reports runtime.

Crystal Reports 2008 Service Pack 1 installs that class, since the Designer needs to connect to Enterprise XI 3.1

But Crystal Reports Server 2008 Service Pack 1 - and its .Net Runtime - isn't out yet.

Sincerely,

Ted Ueda

Former Member
0 Kudos

Hi Ted,

Thanks for your prompt reply. Do you have a rough idea of when Crystal Reports Server 2008 service pack 1 will be released? Is there a beta version available that we could test?

Thanks

former_member184995
Active Contributor
0 Kudos

The Q2 timeframe is what I last heard, but of course that could change.

Answers (0)