cancel
Showing results for 
Search instead for 
Did you mean: 

Check the filtering for an index

Former Member

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi Sri,

When you create an index, you have to assign a crawler.

You can see crawler parameter.

For more information you can read:

http://help.sap.com/saphelp_nw04/helpdata/en/e6/ed5b825590c74e8a963289450f98f6/frameset.htm

Patricio.

Former Member
0 Kudos

Hi Patricio,

Thanks for your prompt reply. I want to reward you points for your kind help but for some reason I don't see the buttons for points. I thought I had marked it as a question. Is there a way by which I can award you points? Sorry, for the inconvenience.

Thanks,

Sri

Former Member
0 Kudos

My friend Sri, if you could solve your problem I am happy man.

Patricio.

Former Member
0 Kudos

Hi Patricio,

Thanks for your suggestion. I did go to "Crawler Parameters" and pulled out the "Result Resource Filter". I then checked "Include links"(since the repository is a database repository) and re-indexed the documents. But still the indexing does not work. Can you please help me? Thanks for your valuable time.

Sincerely,

Sri

Former Member
0 Kudos

Sri,

In order to narrow down this problem, I would like to know if you saw in System Administration\Monitoring\KM\Trex monitor,what is server status, display your queves and entries.

If your index has any problem, here you can see that.

I am going to wait your comments,

Patricio.

Former Member
0 Kudos

Hi Patricio,

Thanks a lot for your reply. When I go to Index Administration, I see a red light for the index. It says that one of the repositories could not be indexed. In Server Status, I see green lights for all the Servers and in Display Queues, it says "Preparation Failed" for 37 documents. In Display Queue Entries, I see only 9 documents for which the Document Status is "OK". Any suggestions on how to proceed? I am greatful to you for all your valuable time and help.

Sincerely,

Sri

Former Member
0 Kudos

Hi Patricio,

One more question. When I reindex the document, does the crawler again start crawling the datasource?

Thanks,

Sri

Former Member
0 Kudos

Sri,

These 9 documents for which the document status is ok, belong your index created by you ?

If your answer is yes, your index is working therefore we can analyze what happended with the other documents.

What kind of repository you try to index ?

In order to narrow down, use standard crawler.

Also, in your index modify data source option in order to point a folder which contain a few document.

Reindex again and in your trex monitor see which is its status.

Patricio.

Former Member
0 Kudos

hi Patricio,

Sorry for interfering with your patient step by step reply.

Hi Sri,

In case you are using a file repository, and few of your documents are getting indexed and few not, while all belong to the same data source, and if the error is "Preparation Failed" for a few documents, then it might be becos the documents that are not indexed are of size > 10KB. And the documents that got indexed are becos they are of size < 10KB.

If it does not help, hope Patricio will continue analysing your problem.

best regds,

Alagammai.

Former Member
0 Kudos

Hi Patricio and Alagammai,

Sorry for the slight delay. Apparently, there seems to be a problem with TRex in the DEV box on which I am currently working. So far, it has not yet been fixed and hence I was not able to work on it. Sorry for that. Hopefully, it should be fixed sometime very soon and I will again continue working on it. Thanks for all your great help and time.

Sincerely,

Sri

raj_balakrishnan3
Participant
0 Kudos

Hi Alagammai and Patricio,

I am having the same problem. Are you sure that only files below 10kb will be indexed? Where can I find information on it? Should I create a CM repository or a FS repository?

Thanks

Raj