cancel
Showing results for 
Search instead for 
Did you mean: 

characteristic

Former Member
0 Kudos

Hello experts,

I tried debugging but seems that characteristic_cell is not executed? other methods are accessible.

How can this be accessed?

Please help. Thanks.

Adette

Accepted Solutions (1)

Accepted Solutions (1)

edwin_harpino
Active Contributor
0 Kudos

hi Adette,

try to put an endless loop in that method

data : l_debug(1).

do.

if l_debug = 'X'.

exit.

endif.

enddo.

and execute the web template, it will hold in that class,

logon sapgui, run transaction sm50, you will see one line with that class name e.g ZSHRMINAPP, cursor on that line and go to menu 'program/mode'->program->debugging, 'yes', in next screen type in l_debug and give X, click pencil icon, and press F5 to go further code line.

hope this helps.

Former Member
0 Kudos

Hi A.H.P,

I tried that but there seems to be no calling of this method?

I am using a z-one that calls the main one. Any way to explain this phenomenon?

Regards,

Adette

edwin_harpino
Active Contributor
0 Kudos

hi Adette,

as you said before, the other methods are accessed ?

you have put the class in table ?

<P><object>

<param name="OWNER" value="SAP_BW"/>

<param name="CMD" value="GET_ITEM"/>

<param name="NAME" value="TABLE_1"/>

<param name="ITEM_ID" value="LIB_TABLE_001"/>

<param name="DATA_PROVIDER" value="DATAPROVIDER_1"/>

<param name="GENERATE_CAPTION" value=""/>

<param name="WIDTH" value="450"/>

<param name="MODIFY_CLASS" value="<b>ZSHRMINAPP</b>"/>

ITEM: TABLE_1

</object></P>

Former Member
0 Kudos

Yes, thats why it was working for the rest. Any idea for consideration? Thanks.

Answers (0)