cancel
Showing results for 
Search instead for 
Did you mean: 

Characteristic with 0 value displays as # - need 0 to display

former_member590127
Participant
0 Kudos
1,873

Hi,

In BEx, I have a characteristic
0SRVCLEN - NUMC,  Len 03
on the report that is displaying as # when it is really a 0.

Note: I said this is a characteristic, not a Key Figure

This makes the output look like this

1
2
3
#

when what the user needs is

0
1
2
3

I know for a fact that the characterisic has a zero in it because I went into the transformation and hard coded the value in a routine to be something obvious (like 77) and it showed up in the query.  I then updated the routine to load a 0 instead of 77 but the query shows #, not 0.

In case it helps any: When I do a display data on the cube, it shows as a blank, not a 0 (which I assume to just be a display setting because I KNOW it is a 0 since I hard coded it).

How can I get the 0 that is in the data to actually show as a 0 in the BEx output (and remember, this is a characteristic, not a Key Figure)?

Thanks!

View Entire Topic
former_member590127
Participant
0 Kudos

Hi Anindya,

I do not have the option to maintain the master data.  I tried CONVERSION_EXIT_ALPHA_INPUT but still have the problem.

I created a new InfoObject and made it Char which worked.

Thanks for your help.

Regards.

anindya_bose
Active Contributor
0 Kudos

Dear Paul

Good to see your problem resolved.

I wish you had authorization to maintain text..its only one time maintenance... You can  data change flexibly if required in future...

You can also try creating a formula variable with replacement path and use that variable in Formula ( in rows)

However, it might slow down the performance.

Regards

Anindya