cancel
Showing results for 
Search instead for 
Did you mean: 

CBTA Edge issue

Diana2
Explorer
0 Kudos
346

Hi Experts,

 

i have an issue when recording using edge, all settings are correct. Issue started after edge update, updated the driver and setting on CBTA but unable to record. logs below.

An exception occured while starting the async recording: SAP.TestAutomationDriver.MSEdge.MSEdgeException: Cannot start the session, status: 33

ERROR | Recording Browser | TADRecorder | An exception occured while starting the async recording: SAP.TestAutomationDriver.MSEdge.MSEdgeException: Cannot start the session, status: 33
at SAP.TestAutomationDriver.MSEdge.MSEdgeCommunicator.Connect(String url, ITADStartContext context)
at SAP.TestAutomationDriver.MSEdge.MSEdgeBrowser.CreateNewIEAndGoToUri(Uri uri, Uri currentWebDriverPort, ITADStartContext context)
at SAP.TestAutomationDriver.MSEdgeFactory.MSEdgeDriverBrowserController..ctor(String url, String windowID, MSEdgeBrowserSessionController sessionMgr, ITADStartContext context)
at SAP.TestAutomationDriver.MSEdgeFactory.MSEdgeControllerFactory.GetPlayerController(String url, ITADStartContext startContext)
at SAP.TestAutomationDriver.Factory.TADriverFactory.GetPlayerController(String url, ITADStartContext context)
at SAPTADriverRecorder.TadRecorderController.StartAsync(Object param)

Diana2
Explorer
0 Kudos
Start Session command failed: WebDriverCmdStartSession: [sessionId 6ca4c67c0be9ac7a0244190886603b86, status 33 - message: session not created: Microsoft Edge failed to start: exited normally. (session not created: DevToolsActivePort file doesn't exist) (The process started from msedge location C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe is no longer running, so msedgedriver is assuming that msedge has crashed.) (Driver info: msedgedriver=122.0.2365.92 (908657ec17be9ad27101d76cdae7448c824b705c),platform=Windows NT 10.0.19045 x86_64)]
Vera_Jiang
Product and Topic Expert
Product and Topic Expert
0 Kudos
We helped you to accept the answer, since there were no updates after 7 days. You can unaccept it anytime if the answer provided was not helpful enough and you have further questions.
View Entire Topic
cherry_sap
Advisor
Advisor

Hello,

I would like to suggest you to check the following first:

1. Make sure to use the latest CBTA version which can be downloaded from SAP ONE Support Launchpad

2. If the security settings from your company are blocking the browsers from using unpacked extensions. Follow the resolution from KBA:3351451 - CBTA - Loading of unpacked extensions is disabled by the administrator.

3. Check if you have Edge ALREADY OPENED on your session when running the CBTA Execution/Recording. If yes, please close it.

If the issue still persists, you can raise an incident with issue details under the component SV-SMG-TWB-CBT.  

Diana2
Explorer
0 Kudos

Hi Cherry,

All CBTA settings are fine and also on the latest version.

Diana2
Explorer
0 Kudos
Hi Cherry
Diana2
Explorer
0 Kudos

Hi Cherry,

The issue is not CBTA but edge crashing when opening via CBTA.

Edge log Start Session command failed: WebDriverCmdStartSession: [sessionId 6ca4c67c0be9ac7a0244190886603b86, status 33 - message: session not created: Microsoft Edge failed to start: exited normally. (session not created: DevToolsActivePort file doesn't exist) (The process started from msedge location C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe is no longer running, so msedgedriver is assuming that msedge has crashed.) (Driver info: msedgedriver=122.0.2365.92 (908657ec17be9ad27101d76cdae7448c824b705c),platform=Windows NT 10.0.19045 x86_64)]