Showing results for 
Search instead for 
Did you mean: 

Cannot set ValidTo-Date in Web-UI: "Date required for attribute"

Former Member
0 Kudos

Hi all

In the Web UI, SAP-PF-Task "Change Identity", I cannot set the Valid-To date. I receive the following error message:

"Unable to set value for attribute Valid Through, detailed information (may not be translated): Date required for attribute"

No matter if I enter the date manually or with the use of the calendar. I also tried different logon languages (and hence different date formatting) and even the SPML dateformat ("yyyy-mm-ddThh:mm:ss").

I didn't change the MX_VALIDTO-attribute (Storage/Data Type: datetime, Presentation: Date).

There's no error written to any IdM-Log nor to the J2EE-Log, so I suppose the date-formatting is checked in WebDynpro.

The error occurs in FireFox 3.5.x as well as in IE7 and IE8.

I use latest versions of all IdM-components available in SAP Marketplace.

Is anyone able to use the Valid-To attribute? What type of date do you enter? Has anyone a solution to this?

Any help appreciated.



Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hello Michael

Can you enter the date when you assign a role?

I try this tasks (from the SAP PF I assume=

With 1/30/2010 it does work and will be saved.

If I use somethimg like 22.1.2010 it complains to enter it in the 1/30/2010 format.

Maybe the language settings your Java box runs on?

Former Member
0 Kudos

Hi Christian

If I enter the date in the "Change Identity"-Task (SAP-PF) in the Entry details of the role it works, so this is the MX_ROLE-related VALID_TO (although I entered a date in the future the role is assigned at once and afterwards I cannot see the dates I entered? But I will look at this another day)

The MX_PERSON-VALID_TO in the same task can not be changed ?

I hope this problem is not language-related; the NetWeaver Java runs on english Suse Linux - so I think the Java runtime is english, too; the UI is in german, my IE / FF are german, MSSQL & Windows-Server where the IdM runtime is installed are german; but this must not be the problem

Anyway thanks for your reply.



Former Member
0 Kudos

Go to the Management Console.

Do a new to Identity Store pass for that MX_PERSON.

Set MX_VALIDTO to 2011-01-01.

What happens if you run that job?

If this works, then the problem is on the Webdynpro I assume.

If not, there might be a problem with the DB. I am not sure though, how the data is actually checked.

I tried to set the data to "blubb" over the MC, then I get the error Date required for attribute.

If I enter 01.01.2011 the job runs without error, however it remains emtyp in the WebUI.

0 Kudos

Hi ppl,

Though this is not related with the date Problem discussed over here , I am getting similar error for some other tasks randomly.


When I try to add a privilege to a business role using a UI task , I get the error " Unable to set value for attribute Assigned Privileges, detailed information (may not be translated): Entry does not exist." . we are finding no clues of where this error comes from as there are no logs .

Also similar error when I try to add Business role to Business role using UI task , I get the error "Unable to set value for attribute Child Roles, detailed information (may not be translated): Entry does not exist."

when I try to add/remove Business role to a user it says " Unable to set value for attribute Member of role, detailed information (may not be translated): Entry does not exist."

This error occurs very randomly as the same task works just fine for some data and not for others.

Can you please give me an idea as to where this error comes from? As many of you told , this might be web dynpro error, if so how to analyse that..If its a database error , then What kind of data analysis we may need to do. I just noticed that there are procedures in the Identty center database to set attribute , but I could not get much out of them. Appreciate your help in this.


Former Member
0 Kudos


Any luck with this I'm seeing the same sporadically.



0 Kudos

Hello Srilakshmi

Did you got any solution for this error, I am also getting same issue


Deepak Gupta

Answers (0)