cancel
Showing results for 
Search instead for 
Did you mean: 

Can't log into BOE system using SAP Authentication when using Document Link

brian_wadell2
Explorer
0 Kudos

Hi all.

We are setting up our dev SBOP 4.0 SP2 system and are working on getting everything configured to our requirements.

What I am currently struggling with is the Document Link functionality.

If you browse to a document (WEBI or Crystal) in the folder view in the BI Launchpad and right click and select Document View, the system presents a static link to the report. The problem is, when I execute that link in another browser window, the system prompts me with the default login screen that consists of the User Name and Password which utilizes the Enterprise authentication by default. Our login authentication is set to SAP everywhere else.

I've already set the parameters for BILaunchpad.properties to allow us to log into the BOE server using our user IDs and that works without a problem. I've also configured the OpenDocument.properties file as well. Neither of these two files seem to have any impact on the screen I'm seeing when I try to use the Document Link. (And yes, I've restarted the tomcat server each time I've made a change to the config files.)

I'm running out of ideas - have any of you encountered this issue before and do you have any suggestions?

Thanks.

-Brian

Accepted Solutions (0)

Answers (2)

Answers (2)

brian_wadell2
Explorer
0 Kudos

For anyone else who may be browsing this topic, I finally found the solution.

When you create a Document Link, the default port is set to 6405. If your system uses a port other than 6405 for the link (in our case it was set to 8080) then change the link to use the correct port. Worked perfectly when I changed the port in the link to 8080.

MirkoT
Explorer
0 Kudos

Hey Brian,

thank you for sharing your experience with us.

We're having exactly your described problem right now and changing the port 6405 to 8080 (in the generated OpenDocument-link) resolves it.

But in my opinion this could only be an temporary workaround.

My question would be: Why does the generated OpenDocument link uses port 6405 instead of port 8080 - which is acctualy the one working?

And is it possible to do any config change, so in the future BOE directly generates OpenDocument-Links with port 8080, instead of 6405?

regards

Mirko

Former Member
0 Kudos

Hi Mirko,

To get the OpenDoc link taking the port number 8080 automatically, you have to perform the following steps:

1. Login to CMC.

2. Navigate to Applications >> Open Document.

3. Right Click >> Processing Settings.

4. It would give us the default OpenDoc link. We need to make change here of the port number; so the next time it would take this port number when we generate the opendoc link from BI Launchpad.

I hope this answers your query.

Regards,

Nakul Mehta

MirkoT
Explorer
0 Kudos

Hi Nakul,

thanks a lot, exactly what i was looking for!

regards

Mirko

Former Member
0 Kudos

Hi,

I have also got this content released in SAP Note 1707774.

Regards,

Nakul

0 Kudos

Hi,

did you copied both properties Files to the "custom" folder?

Regards

-Seb.

brian_wadell2
Explorer
0 Kudos

Yes, both files are in the custom folder.

0 Kudos

Hi,

i saw this also a couple of times that the changes to the "custom" folder wont take affect.

Try the following:

1. Stop the Tomcat

2. Rename the properties file in the custom folder

3. take a backup of the properties file from the config folder

4. make the changes to the properties file in the config folder

5. start tomcat

Maybe this will solve the issue but if you deploy a new Fix Pack or Service Pack these Settings will get override.

If this solved your problem i would recommend you open a Support Message with the SAP Support.

Regards

-Seb.

brian_wadell2
Explorer
0 Kudos

Thanks for the suggestion. Unfortunately it didn't work.

When I remove the files from the custom folder and modify the files in the default folder, the changes to the files in the default folder are ignored - the server uses the default settings as if there weren't any configuration lines specified in the config files. (I did restart the tomcat server.)

0 Kudos

Hi,

try to move the properties files away from the custom folder and try again.

Regards

-Seb.

brian_wadell2
Explorer
0 Kudos

I did - I backed the files up to a backup folder and completely deleted them from the custom folder.

0 Kudos

Hi,

the last thing we could do is deleting the Tomcat Cache like:

- Stop the Tomcat

- Delete the "localhost" Folder under the "Catalina" Folder

- Start the Tomcat

- Whait about 10 min.

- Try again.

If this also doesnt help sou should log a Case with the SAP Support.

Regards

-Seb.

Former Member
0 Kudos

Just to be clear you would want to clear the cache from the <BOINSTALL>\Tomcat6\work\Catalina\localhost

0 Kudos

Hi,

yes. delete that localhost Folder.

Regards

-Seb.