cancel
Showing results for 
Search instead for 
Did you mean: 

BW red request from BODS Job

Former Member
0 Kudos
669

I have an issue that I am having a table as source from oracle database and my target is BW datasource

When I run infopackage from BW the work is running successfully and green request but when I run the job from data services client the job finished successfully and it created generated infopackage but the request is in red and I checked the number of records and it is ok

So I need to know how I can run job from designer and I got green color

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

This issue occurs if you fill the third party parameters in the onfo-package, when run job from DS. These parameters must be filled if you run the info-package from BW. So, I always have 2 info-packages for each DS-datasource in BW.

But you have to fill tech.name of DS info-packages on the DS side, in properties of datasource -> attributes -> Info Package name (so, will not generate new one info package for each job run)

Hope, it will help.

Best wishes.

Asya

Answers (1)

Answers (1)

severin_thelen
Contributor
0 Kudos

Hello Mohamed,

we had the same issue. In our opinion it is a bug in DS. The DS think, there is a primary key error (what is wrong) and communicate this error to the BW. So the BW set the request to red.

A work around is to extend the primary key on a second column.

Regards

Severin

severin_thelen
Contributor
0 Kudos

Has someone another way to correct the issue? So I read that the cause of the issue is a wrong RFC connection, but I can not find a mistake.
Additional I can not start a DS job from the BW. So the BW job has a yellow status, during the DS log shows an error message. But the DS error message is just a row of random characters.

Regards

Severin

former_member198401
Active Contributor
0 Kudos

Hi Severin,

We also faced the issue when we ran the BODS Job to populate a SAP BW Target running on DEV Application Server and the job never ran successfully. It always gave the Duplicates cannot be loaded in AL_BW_REQUEST table error . When we tried to delete the contents of AL_BW_REQUEST table it gave another error that Request Number is not Valid for AL_BW_REQUEST table(REQUESTID column). We havent modified or added the Primary Key in AL_BW_REQUEST table..

The potential reason for our issue could be the SAP BW Application Server upgrade from 3.1 to 7.0 in DEV environment.

The same job we tested pointing the data store in DS to Quality BW Application Server and the job finished loading into SAP BW Target successfully.

We have raised a ticket with SAP for this issue.

Regards

Arun Sasi

severin_thelen
Contributor
0 Kudos

Please let me know, if SAP has a solution for this issue.

former_member198401
Active Contributor
0 Kudos

Hi Severin,

SAP Support doesnt have any solution for this issue.I would recommend that no changes should be done to AL_BW_REQUEST metadata table.

What I was able to find in our case was that after the upgrade of SAP BW Server from 3.1 to 7.0 in our DEV environment, the target structure was auto generated for e.g a Transactional data structure INDVEJLEVR_PB was changed to INDVEJLEVR_CB. An easiest solution would be to reimport the Master or Transactional target structure and check if there are any changes occurred. We reimported the target and then the job ran without any error.

Hope this helps!!

Regards

Arun Sasi