Showing results for 
Search instead for 
Did you mean: 

Build MTA failed in SAPBTP (Free Tier)

Active Contributor
0 Kudos

This week the Free Tier of SAPBTP arrived and the first thing was to test whether I'm able to connect our on-prem systems via cloud connector and create launchpad apps.

I failed at building the MTA project, so I've tried to repeat step by step the things I've learned in the tutorial group "Group: Build an SAP Fiori App that Consumes Data from an On-Premise System"

-> I've got the same errors (so I was not so wrong). I've repeated every step on the SAPBTP trial and it worked like described in the tutorials.

The first problemes I got already in the tutorial "Create an SAP Fiori App Using SAP Business Application Studio" in Step 4: Run the App Locally in the Dev Space.

Console output:

user: FioriDemo $ cd "/home/user/projects/FioriDemo/businesspartners"
npm run start
user: businesspartners $ npm run start
npm WARN lifecycle The node binary used for scripts is /extbin/bin/node but npm is using /opt/nodejs/node-v14.16.0-linux-x64/bin/node itself. Use the `--scripts-prepend-node-path` option to include the path for the node binary npm was executed with.

> businesspartners@0.0.1 start /home/user/projects/FioriDemo/businesspartners
> fiori run --open 'index.html?sap-client=002'

info Add:Deploy-config Using: @sap/fiori:deploy-config
info Add:Flp-config Using: @sap/fiori:flp-config
Fiori tools CLI.

⚠️  Process Failed With Error

Error Message:
[npm translator] Could not locate module @sap/ui5-builder-webide-extension via resolve logic (error: Cannot find module '@sap/ui5-builder-webide-extension/package.json' from '/home/user/projects/FioriDemo/businesspartners') or in a collection

For details, execute the same command again with an additional '--verbose' parameter

This error I was able to solve by installing additional npm modules:

user: businesspartners $ cd ..
user: FioriDemo $ npm install @sap/ui5-builder-webide-extension
user: FioriDemo $ npm install ui5-task-zipper

But in the tutorial "Build and Deploy Your SAP Fiori App to SAP Business Technology Platform" in Step 1: "Build the application" I'm finally stuck. I'm not able to build the MTA project.

Console output for the build process:

> Executing task: mbt build -s '/home/user/projects/FioriDemo'; sleep 2; <

[2021-07-03 11:07:53]  INFO Cloud MTA Build Tool version 1.1.1
[2021-07-03 11:07:53]  INFO generating the "Makefile_20210703110753.mta" file...
[2021-07-03 11:07:53]  INFO done
[2021-07-03 11:07:53]  INFO executing the "make -f Makefile_20210703110753.mta p=cf mtar= strict=true mode=" command...
[2021-07-03 11:07:53]  INFO validating the MTA project
[2021-07-03 11:07:53]  INFO validating the MTA project
[2021-07-03 11:07:53]  INFO building the "FioriDemo-destination-content" module...
[2021-07-03 11:07:53]  INFO the "FioriDemo-destination-content" module was not built because the "no-source" build parameter is set to "true"
[2021-07-03 11:07:53]  INFO finished building the "FioriDemo-destination-content" module
[2021-07-03 11:07:53]  INFO building the "nsbusinesspartners" module...
[2021-07-03 11:07:53]  INFO executing the "npm install" command...
..npm WARN deprecated request-promise@4.2.6: request-promise has been deprecated because it extends the now deprecated request package, see
npm WARN deprecated request@2.88.2: request has been deprecated, see
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated uuid@3.4.0: Please upgrade  to version 7 or higher.  Older versions may use Math.random() in certain circumstances, which is known to be problematic.  See for details.
..npm WARN tar ENOENT: no such file or directory, open '/home/user/projects/FioriDemo/businesspartners/node_modules/.staging/psl-369a1cdd/package.json'
npm ERR! code E404
npm ERR! 404 Not Found - GET http://nginx-redirector.repo-cache.svc.cluster.local/repository/appstudio-npm-group/@types/node/-/no...
npm ERR! 404 
npm ERR! 404  '@types/node@*' is not in the npm registry.
npm ERR! 404 You should bug the author to publish it (or use the name yourself!)
npm ERR! 404 It was specified as a dependency of 'businesspartners'
npm ERR! 404 
npm ERR! 404 Note that you can also install from a
npm ERR! 404 tarball, folder, http url, or git url.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/user/.npm/_logs/2021-07-03T11_07_58_263Z-debug.log
[2021-07-03 11:07:58] ERROR could not build the "nsbusinesspartners" module: could not execute the "npm install" command: exit status 1
make: *** [Makefile_20210703110753.mta:37: nsbusinesspartners] Error 1
Error: could not build the MTA project: could not execute the "make -f Makefile_20210703110753.mta p=cf mtar= strict=true mode=" command: exit status 2

Any ideas?

Active Contributor
0 Kudos

Hi Uwe,

are you sure that you've chosen the "Basic Multitarget Application"? There is also "Multitarget Application Module Base Generator". I've used "Basic Multitarget Application" in my new Pay As You Go Account and where able to run it in BAS and also to deploy and run in the Launchpad.


View Entire Topic
0 Kudos

I've had this issue too. Apparently there was an issue with the npm cache. I had an error when executing 'npm i', which resulted in this 'Could not locate ...' message.

What I had to do was 'npm clear cache --force'. And then I could do 'npm i' with no errors and the other errors disappeared too.

I think that's why se38 solution worked, because there was a new cache.