Showing results for 
Search instead for 
Did you mean: 

Broken DCs???

Former Member
0 Kudos

Hi All,

I have developed a Webdynpro component and then released the activity successfully from the developer studio. In the Assembly tab it gets failed.

When i see the log it says broken DCs. In the Broken DCs the <u>compiled state is showing red in color</u> and all others are green. But my WD Component is error free and it not use any used DCs too.

1) What is the cause for it??? I assembled the components in the inconsistent state and then tranported to the other system where i m not able to find the deployed Wd Content.

2) I created another activity for the same component and try to activate but this time the activation fails in NWDS itself. Log says "No build log available. The Dc has not been built in this request" Why???

3) When i compare workspaces in DTR one file alone says deactivated due to name-collisions???

Can some one help me out with this issues????

Thanks and Regards,


Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Nagarajan,

1) Probably No.3. Name collision means you have transported (integrated) a file/resource into a workspace where a file with the same name already existed. I'm not sure if CBS recognizes that but the original request log on CBS should give more details.

2) What does the request log give as reason why no build was performed?



Former Member
0 Kudos


Solved the problem.

Marc - Really strange to see the build and request log not giving any reasons for the error.

K let me put the solution i tried to resolve the above issues and made transport successfully.

1) Added the dedef file from DTR explictly to an activity and then activated the same.

2) when this activity through in CBS the development track_d DCs turned green.

3) But Cons were still in red.

4) Explicitly imported the cons track inside the NWDS and did a manual sync to DCs and activated.

Fianlly got the taste of the sweet.

Thanks and regards,


Answers (0)