cancel
Showing results for 
Search instead for 
Did you mean: 

brbackup using ftp

Former Member
0 Kudos

hi All,

i'm trying to perform a brbackup using FTP with the following parameters set in initSID.sap

stage_copy_cmd = ftp

remote_user = orasid

remote_host = rmhost

according to the help document. If password is not set for remote_user, brbackup uses the password of the database user (in this case, orasid, which run the brbackup command. this is right?)

however, when running brbackup, i've got the following error:

Connected to rmhost Port 21.

220 Microsoft FTP Service

331 Password required for orasid.

530 User orasid cannot log in.

530 Please login with USER and PASS.

530 Please login with USER and PASS.

221

Both orasid has the same password on the sap server and the ftp server. It runs well when the password is specified in the initSID.sap profile. However, due to security concerns, I do not wish to have the password specified in the profile.

Thank you very much for any help!.

Regards

Marc

Accepted Solutions (1)

Accepted Solutions (1)

0 Kudos

Hello Marc,

Please, check the following thread as it has a similar question.

From the documentation:

<i><b>remote_user</b>

Use this parameter to specify the user for a remote host, if you want to make a backup to a remote tape or disk.

Syntax: remote_user = <user>

Default: none

If you use the ftp network to transfer data you can also specify the password which BRBACKUP uses to log on to the remote host.

remote_user = "<user> <password>"

<b>If you do not specify a password, BRBACKUP uses the password of the database user. If this is the case, the two user passwords must be the same</b>.</i>

Your setting is the following:

stage_copy_cmd = ftp

<b>remote_user = orasid</b>

remote_host = rmhost

Orasid is NOT a database user BUT the Operating system User.

FTP expect a password and BRBACKUP is not providing it because

1) you didn't specify it on the <b>remote_user</b> parameter

2) you didn't specify a database user on the <b>remote_use</b>r parameter

Former Member
0 Kudos

hi Peter & Fidel,

thanks for the reply.

From what i understand, the parameter remote_user refers to the O/S user at the remote host, not the database user. What confuse me now is that if the password is provided, that the database user password will be used.

In fact, when I specified the parameter remote_user with a password, like remote_user="orasid passwd", it works. In the Windows FTP server, I have created a O/S user named orasid as well. However, this is not accepted as the password of the user, in this case, is exposed.

I've tried using smb mount over the NT shared directory, but the connection is not stable, hence i would like to explore this option.

Has anyone ever run successfully w/o specifying the password?

Thanks again for the reply.

Regards

marc

0 Kudos

Hello Marc,

yes and no

I'll (try to) explain

on the parameter <b>remote_user</b> you have to speciy the name and password to be used on the ftp connection.

1) yes it is an operating system user on the destination server

2) you <b>MUST</b> provide a password but, if the name of the remote operating system user matches the database user then BRCONNECT is able to get that information.

If

- your DB user is SAPR3

and

- the remote os user on the ftp server is also SAPR3

and

- both have the same password

then

- you can ommit the password from the parameter

That is the ONLY situation when the password can be ommited.

Former Member
0 Kudos

Fidel,

we have more than one of them.

Is the right user the one specifed arround the<b> -u</b> switch of br*tools?

Peter

0 Kudos

Hello Peter,

Yes you are correct.

The password is taken from the Option "-u <user>/<password>"

Of course, it does not work for the OPS$ user.

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Marc,

you should create an user in rmhost, to give the usser the write access.

Here are the parameters you require:

backup_dev_type = stage

stage_root_dir = folder/subfolder

archive_stage_dir = folder/subfolder

stage_copy_cmd = ftp

remote_host = rmnost

remote_user = "user password"

Regards

P.S. please Award points, if helpful

Former Member
0 Kudos

which system is trying to connect to the ftp server?

A windows based SAP installation?

Peter

Former Member
0 Kudos

A Linux-based SAP installation connecting to the Windows FTP server

Former Member
0 Kudos

would'nt it be easier to mount a network share of the windows box via samba into the linux box filesystem?

according the password discussion.

orasid is not the database user. I would expect as database user "system" or "/"aka "SYS"). if / is used there may be no password, because this one will be identified externally.

peter